summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPierre Choffet2019-10-17 11:56:39 -0400
committerPierre Choffet2019-10-17 12:01:25 -0400
commitc50d81a66df17ee7a0ccd3d739734227eb03a475 (patch)
tree35958281fb090666bce198f3b40e58cf02283b07
parent06cc946ba8c3f1bddb9c723ae309ca4f482dfc66 (diff)
downloadaur-c50d81a66df17ee7a0ccd3d739734227eb03a475.tar.gz
Force use of system libsamplerate
-rw-r--r--.SRCINFO6
-rw-r--r--ChangeLog4
-rw-r--r--PKGBUILD11
3 files changed, 14 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2ff499ce2fbd..d6b1bb21bb4b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Thu May 2 20:57:19 UTC 2019
pkgbase = return-to-the-roots-git
pkgdesc = Free/libre implementation of The Settlers II game engine
- pkgver = r4319.fbaa134b
+ pkgver = r4467.3af7f7c76
pkgrel = 1
url = https://siedler25.org/
install = return-to-the-roots.install
@@ -17,11 +15,13 @@ pkgbase = return-to-the-roots-git
makedepends = curl
makedepends = lua52
makedepends = miniupnpc
+ makedepends = libsamplerate
depends = boost-libs
depends = libgl
depends = sdl_mixer
depends = miniupnpc
depends = lua52
+ depends = libsamplerate
optdepends = siedler2-data
provides = return-to-the-roots
conflicts = return-to-the-roots
diff --git a/ChangeLog b/ChangeLog
index de88329cad66..334ab05d16c5 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,7 @@
+2019-10-17 Pierre Choffet <peuc@wanadoo.fr>
+ * r4467.3af7f7c76 :
+ Force build to use system libsamplerate
+
2019-05-02 Pierre Choffet <peuc@wanadoo.fr>
* r4319.fbaa134b-1 :
Update build after upstream changes
diff --git a/PKGBUILD b/PKGBUILD
index d0cb7930a709..dcb8c2c6ea7d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Pierre Choffet <peuc@wanadoo.fr>
pkgname=return-to-the-roots-git
-pkgver=r4319.fbaa134b
+pkgver=r4467.3af7f7c76
pkgrel=1
pkgdesc="Free/libre implementation of The Settlers II game engine"
arch=("x86_64")
url="https://siedler25.org/"
license=("GPL3")
-makedepends=("cmake" "git" "boost" "mesa" "sdl_mixer" "curl" "lua52" "miniupnpc")
-depends=("boost-libs" "libgl" "sdl_mixer" "miniupnpc" "lua52")
+makedepends=("cmake" "git" "boost" "mesa" "sdl_mixer" "curl" "lua52" "miniupnpc" "libsamplerate")
+depends=("boost-libs" "libgl" "sdl_mixer" "miniupnpc" "lua52" "libsamplerate")
optdepends=("siedler2-data")
conflicts=("return-to-the-roots" "s25rttr" "s25rttr-nightly-bin")
provides=("return-to-the-roots")
@@ -75,7 +75,10 @@ build() {
# Build
mkdir -p build && cd build
- cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX="${pkgdir}/usr" -DBUILD_TESTING=Off -RTTR_BINDIR="bin" -DRTTR_DATADIR="share/s25rttr" -DRTTR_LIBDIR="lib/s25rttr" -DRTTR_EXTRA_BINDIR="bin" ..
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX="${pkgdir}/usr" \
+ -DBUILD_TESTING=Off -RTTR_BINDIR="bin" -DRTTR_DATADIR="share/s25rttr" \
+ -DRTTR_LIBDIR="lib/s25rttr" -DRTTR_EXTRA_BINDIR="bin" \
+ -DRTTR_USE_SYSTEM_SAMPLERATE=On ..
make
}