summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJ0k3r2014-02-07 20:01:46 +0100
committerJ0k3r2014-02-07 20:58:56 +0100
commitb00300e3f1ae68c92e3b9eede1adfb17981b2220 (patch)
tree80f13d6b934b7ba533280a44d7181304b61d0678
downloadaur-b00300e3f1ae68c92e3b9eede1adfb17981b2220.tar.gz
AUR4 split: Initial Commit
-rw-r--r--.SRCINFO28
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD80
-rw-r--r--reus.changelog27
-rw-r--r--reus.desktop11
5 files changed, 152 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0158d0b87a8a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = reus
+ pkgdesc = A god game in which you take control of nature through the hands of mighty giants
+ pkgver = 1389636757
+ pkgrel = 1
+ epoch = 1
+ url = http://www.reusgame.com/
+ changelog = reus.changelog
+ arch = i686
+ arch = x86_64
+ groups = games
+ license = unknown
+ makedepends = unzip
+ makedepends = imagemagick
+ depends = gcc-libs
+ depends = libvorbis
+ depends = openal
+ depends = libtheora
+ depends = freetype2
+ depends = sdl2
+ source = hib://reus_linux_1389636757-bin
+ source = reus.desktop
+ source = reus.changelog
+ sha256sums = e9f2306bbbf8908b1dd4d09519959316a31df38002e80bfb74116cd338c50584
+ sha256sums = 91e5b44bed07a180f591687d199fb88507a80f91cbea6cb6b42d19bfce73323a
+ sha256sums = SKIP
+
+pkgname = reus
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ae76a8b9108f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+pkg/
+src/
+*.pkg.*
+*.src.*
+reus_beta2_lin_bin
+reus_linux_*-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..13b4cadac8ca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,80 @@
+# Maintainer: J0k3r <moebius282@gmail.com>
+
+pkgname=reus
+pkgver=1389636757
+pkgrel=1
+epoch=1
+pkgdesc="A god game in which you take control of nature through the hands of mighty giants"
+url="http://www.reusgame.com/"
+license=('unknown')
+arch=('i686' 'x86_64')
+groups=("games")
+depends=('gcc-libs' 'libvorbis' 'openal' 'libtheora' 'freetype2' 'sdl2')
+makedepends=('unzip' 'imagemagick')
+changelog="${pkgname}.changelog"
+_purgelibs=('libtheora.so.0' 'libtheoradec.so.1' 'libvorbis.so.0' 'libopenal.so.1' 'libogg.so.0' 'libfreetype.so.6' 'libSDL2-2.0.so.0')
+_binver=$pkgver
+_archivename="${pkgname}_linux_${_binver}-bin"
+source=("hib://${_archivename}"
+ "${pkgname}.desktop"
+ "${pkgname}.changelog")
+sha256sums=('e9f2306bbbf8908b1dd4d09519959316a31df38002e80bfb74116cd338c50584'
+ '91e5b44bed07a180f591687d199fb88507a80f91cbea6cb6b42d19bfce73323a'
+ 'SKIP')
+PKGEXT=".pkg.tar"
+
+
+# You can download the Humble Indie Bundle file manually, or you can configure
+# DLAGENTS in makepkg.conf to auto-download.
+#
+# For example, to use hib-dlagent to download files set something like this in
+# your makepkg.conf (change/add -k and add -u/-p to your needs):
+# DLAGENTS=('hib::/usr/bin/hib-dlagent -k 1a2b3c -o %o $(echo %u | cut -c 7-)')
+#
+# To auto-search through a directory containing Humble Bundle downloads, you
+# could set:
+# DLAGENTS=('hib::/usr/bin/find /path/to/downloads -name $(echo %u | cut -c 7-) -exec ln -s \{\} %o \; -quit')
+DLAGENTS+=('hib::/usr/bin/echo "Could not find %u. Download manually to \"$(pwd)\" or setup hib:// DLAGENT in /etc/makepkg.conf."; exit 1')
+
+
+package()
+{
+ mkdir -p "${pkgdir}/opt/${pkgname}/"
+
+# unzip is stupid..
+ unzip -qq "${srcdir}/${_archivename}" -d "${pkgdir}/opt/tmp/" 'data/*' || true
+
+ mv "${pkgdir}/opt/tmp/data/"* "${pkgdir}/opt/${pkgname}/"
+ rm -r "${pkgdir}/opt/tmp/"
+
+ if [ "$CARCH" = "x86_64" ]; then
+
+ rm -r "${pkgdir}/opt/${pkgname}/lib/"
+ rm "${pkgdir}/opt/${pkgname}/${pkgname^}.bin.x86"
+ for i in "${_purgelibs[@]}"; do
+ rm "${pkgdir}/opt/${pkgname}/lib64/${i}"
+ done
+
+ else
+
+ rm -r "${pkgdir}/opt/${pkgname}/lib64/"
+ rm "${pkgdir}/opt/${pkgname}/${pkgname^}.bin.x86_64"
+ for i in "${_purgelibs[@]}"; do
+ rm "${pkgdir}/opt/${pkgname}/lib/${i}"
+ done
+
+ fi
+
+# patching the included startup script so it supports being symlinked
+ sed -i -e 's|`dirname "$0"`|$(dirname \"$(readlink -f \"$0\")\")|' "${pkgdir}/opt/${pkgname}/Reus"
+
+ mkdir -p "${pkgdir}/usr/bin/"
+ ln -s "/opt/${pkgname}/Reus" "${pkgdir}/usr/bin/${pkgname}"
+
+# the spec only specifies png, svg and xpm..
+
+ convert "${pkgdir}/opt/${pkgname}/Reus.bmp" "${pkgdir}/opt/${pkgname}/${pkgname}.png"
+
+ install -D -m644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -D -m644 "${pkgdir}/opt/${pkgname}/${pkgname}.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+} \ No newline at end of file
diff --git a/reus.changelog b/reus.changelog
new file mode 100644
index 000000000000..a79b1782c7ea
--- /dev/null
+++ b/reus.changelog
@@ -0,0 +1,27 @@
+2013-01-08 | J0k3r <moebius282@gmail.com>
+
+ * reus-beta2-1:
+ - Inital Release ( reus_beta2_lin_bin )
+
+2014-01-08 | J0k3r <moebius282@gmail.com>
+
+ * reus-beta2-1:
+ - Added Changelog
+ - Minor Fixes
+
+2014-01-09 | J0k3r <moebius282@gmail.com>
+
+ * reus-1:1389211698-1:
+ - Updated to new binary
+ - Set epoch; using new version system
+ - Removed bundled sdl2; using system one
+
+2014-01-11 | J0k3r <moebius282@gmail.com>
+
+ * reus-1:1389317353-1:
+ - Updated to new binary
+
+2014-01-17 | J0k3r <moebius282@gmail.com>
+
+ * reus-1:1389636757-1:
+ - Updated to new binary
diff --git a/reus.desktop b/reus.desktop
new file mode 100644
index 000000000000..263b817042a8
--- /dev/null
+++ b/reus.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Encoding=UTF-8
+Value=1.0
+Type=Application
+Name=Reus
+Comment=A god game in which you take control of nature through the hands of mighty giants
+Icon=reus.png
+Exec=reus
+Categories=Game;
+Path=/opt/reus
+