summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author466202023-10-08 14:13:08 -0400
committer466202023-10-08 14:13:08 -0400
commit3637645bc8885c12980939c90015b4104d969dd2 (patch)
tree25e9d6691145d37132add473505d1875bc8bac79
downloadaur-3637645bc8885c12980939c90015b4104d969dd2.tar.gz
init v0.119.0
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD19
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0bdb3ecaf05f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = revanced-integrations-bin
+ pkgdesc = Integrations containing helper classes for ReVanced. Originally maintained by Vanced.
+ pkgver = 0.119.0
+ pkgrel = 1
+ url = https://github.com/revanced/revanced-integrations
+ arch = any
+ license = GPL3
+ depends = revanced-cli
+ conflicts = revanced-integrations
+ source = integrations-0.119.0.apk::https://github.com/revanced/revanced-integrations/releases/download/v0.119.0/revanced-integrations-0.119.0.apk
+ source = https://github.com/revanced/revanced-integrations/raw/v0.119.0/LICENSE
+ sha256sums = fe4eb9498b677030e180c7e93740a66ab6156e33fc0e7b40503f97f8965d79d9
+ sha256sums = 3972dc9744f6499f0f9b2dbf76696f2ae7ad8af9b23dde66d6af86c9dfb36986
+
+pkgname = revanced-integrations-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..367dc618d317
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: MedzikUser <nivua1fn@duck.com>
+pkgname='revanced-integrations-bin'
+pkgver="0.119.0"
+pkgrel=1
+pkgdesc='Integrations containing helper classes for ReVanced. Originally maintained by Vanced.'
+arch=('any')
+url="https://github.com/revanced/revanced-integrations"
+license=('GPL3')
+depends=('revanced-cli')
+conflicts=('revanced-integrations')
+source=("integrations-${pkgver}.apk::${url}/releases/download/v${pkgver}/revanced-integrations-${pkgver}.apk"
+ "${url}/raw/v${pkgver}/LICENSE")
+sha256sums=('fe4eb9498b677030e180c7e93740a66ab6156e33fc0e7b40503f97f8965d79d9'
+ '3972dc9744f6499f0f9b2dbf76696f2ae7ad8af9b23dde66d6af86c9dfb36986')
+
+package() {
+ install -Dm 644 integrations-${pkgver}.apk "${pkgdir}/usr/share/revanced/integrations.apk"
+ install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}