summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBioArchLinuxBot2022-12-24 19:43:12 +0000
committerBioArchLinuxBot2022-12-24 19:43:12 +0000
commita290c41d0702c8e51c87106d9c66b87c1b5ee647 (patch)
tree5ee1d3d377723bb5e26987f144afaa5dfe2da1e2
parent70e193e56334e12d48c08435958a8fe691186066 (diff)
downloadaur-a290c41d0702c8e51c87106d9c66b87c1b5ee647.tar.gz
[lilac] updated to 1.2.1-1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD15
-rw-r--r--rb.patch73
3 files changed, 88 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5185a7406313..14f8b8c5dab2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = revbayes-mpi
pkgdesc = Bayesian Phylogenetic Inference Using Graphical Models and an Interactive Model-Specification Language https://doi.org/10.1093/sysbio/syw021
- pkgver = 1.2.0
- pkgrel = 5
+ pkgver = 1.2.1
+ pkgrel = 1
url = https://github.com/revbayes/revbayes
arch = x86_64
license = GPL3
@@ -17,7 +17,9 @@ pkgbase = revbayes-mpi
provides = revbayes
conflicts = lrzsz
conflicts = revbayes-mpi
- source = git+https://github.com/revbayes/revbayes.git#tag=v1.2.0
+ source = git+https://github.com/revbayes/revbayes.git#tag=v1.2.1
+ source = rb.patch
md5sums = SKIP
+ md5sums = f5af0159704f049f8269584883bcaa80
pkgname = revbayes-mpi
diff --git a/PKGBUILD b/PKGBUILD
index 27022a8c3639..53cccf3b300f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
pkgname=revbayes-mpi
_pkgname=revbayes
-pkgver=1.2.0
-pkgrel=5
+pkgver=1.2.1
+pkgrel=1
pkgdesc="Bayesian Phylogenetic Inference Using Graphical Models and an Interactive Model-Specification Language https://doi.org/10.1093/sysbio/syw021"
arch=(x86_64)
url="https://github.com/revbayes/revbayes"
@@ -10,18 +10,23 @@ depends=('gcc-libs' 'boost-libs' 'openlibm' 'openmpi')
makedepends=('boost' 'meson' 'ninja' 'cmake' 'git')
conflicts=('lrzsz' 'revbayes-mpi')
provides=('revbayes')
-source=("git+$url.git#tag=v$pkgver")
-md5sums=('SKIP')
+source=("git+$url.git#tag=v$pkgver"
+ "rb.patch")
+md5sums=('SKIP'
+ 'f5af0159704f049f8269584883bcaa80')
prepare() {
cd $srcdir/$_pkgname
+ # fix lib issue
+ patch -p1 < $srcdir/rb.patch
+
git submodule update --init --recursive
./projects/meson/generate.sh
}
build() {
cd $srcdir/$_pkgname
- CXXFLAGS="${CXXFLAGS} -std=c++14" arch-meson build \
+ arch-meson build \
--buildtype release \
-Dmpi=true
ninja -C build
diff --git a/rb.patch b/rb.patch
new file mode 100644
index 000000000000..e23cd74436dd
--- /dev/null
+++ b/rb.patch
@@ -0,0 +1,73 @@
+From bbae33847c4dc24ffbd3bab2afceb4e3e0bbe757 Mon Sep 17 00:00:00 2001
+From: Kuoi <kuoi@bioarchlinux.org>
+Date: Sat, 24 Dec 2022 23:58:29 +0800
+Subject: [PATCH 1/3] add memory lib
+
+---
+ src/revlanguage/functions/UserFunction.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/revlanguage/functions/UserFunction.cpp b/src/revlanguage/functions/UserFunction.cpp
+index fe7a958ba0..d7ffe11ea4 100644
+--- a/src/revlanguage/functions/UserFunction.cpp
++++ b/src/revlanguage/functions/UserFunction.cpp
+@@ -10,6 +10,7 @@
+ #include "UserFunction.h"
+ #include "UserFunctionDef.h"
+ #include "Workspace.h"
++#include <memory>
+ #include "Argument.h"
+ #include "Environment.h"
+ #include "RevObject.h"
+
+From ad3f390b67a88923dd39702560510ea91480da77 Mon Sep 17 00:00:00 2001
+From: Kuoi <kuoi@bioarchlinux.org>
+Date: Sun, 25 Dec 2022 00:25:42 +0800
+Subject: [PATCH 2/3] add memory
+
+---
+ src/revlanguage/workspace/RevVariable.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/revlanguage/workspace/RevVariable.cpp b/src/revlanguage/workspace/RevVariable.cpp
+index 0736ac9663..ded40ee106 100644
+--- a/src/revlanguage/workspace/RevVariable.cpp
++++ b/src/revlanguage/workspace/RevVariable.cpp
+@@ -2,6 +2,7 @@
+ #include <string>
+ #include <sstream>
+ #include <vector>
++#include <memory>
+
+ #include "Argument.h"
+ #include "RbException.h"
+
+From 8c78d8a84d3dd1fa57f765ebfa1332de37c7a315 Mon Sep 17 00:00:00 2001
+From: Kuoi <kuoi@bioarchlinux.org>
+Date: Sun, 25 Dec 2022 00:26:27 +0800
+Subject: [PATCH 3/3] adjust position
+
+---
+ src/revlanguage/functions/UserFunction.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/revlanguage/functions/UserFunction.cpp b/src/revlanguage/functions/UserFunction.cpp
+index d7ffe11ea4..33961156cc 100644
+--- a/src/revlanguage/functions/UserFunction.cpp
++++ b/src/revlanguage/functions/UserFunction.cpp
+@@ -3,6 +3,7 @@
+ #include <list>
+ #include <string>
+ #include <vector>
++#include <memory>
+
+ #include "RbException.h"
+ #include "Signals.h"
+@@ -10,7 +11,6 @@
+ #include "UserFunction.h"
+ #include "UserFunctionDef.h"
+ #include "Workspace.h"
+-#include <memory>
+ #include "Argument.h"
+ #include "Environment.h"
+ #include "RevObject.h"