summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorantonino2021-02-16 19:19:18 +0100
committerantonino2021-02-16 19:19:18 +0100
commit381abcccdbb5646973765ed05e04f62e66f69db6 (patch)
tree7418f68a2ab1f14fa142a0ff149bc7c20a561872
parent7aa4da8e63b812a7285b2445aee9098f1e698640 (diff)
downloadaur-381abcccdbb5646973765ed05e04f62e66f69db6.tar.gz
added md5 checksums and better handling of submodules
-rw-r--r--PKGBUILD26
1 files changed, 22 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 881943977a4c..be080c3658d9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,8 +9,22 @@ provides=('revc')
license=('none')
install=$pkgname.install
-source=('git://github.com/GTAmodding/re3.git' 'launch.sh' 'GTAVC.desktop')
-md5sums=('SKIP' 'SKIP' 'SKIP')
+source=(
+ 'git://github.com/GTAmodding/re3.git#branch=miami'
+ 'git+https://github.com/aap/librw.git'
+ 'git+https://github.com/xiph/ogg.git'
+ 'git+https://github.com/xiph/opus.git'
+ 'git+https://github.com/xiph/opusfile.git'
+ 'launch.sh'
+ 'GTAVC.desktop')
+md5sums=(
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ '9eb2aff2687f8cc735ea93e0460f07e0'
+ '2991b7cf6751274bfdccc7b6f0272129')
pkgver() {
cd "$srcdir/re3"
@@ -20,8 +34,12 @@ pkgver() {
prepare() {
cd "$srcdir/re3"
- git submodule update --init --recursive
- git checkout miami
+ git submodule init
+ for submod in librw ogg opus opusfile
+ do
+ git config "submodule.vendor/$submod.url" "../$submod"
+ done
+ git submodule update
}
build() {