summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichał Lisowski2020-10-05 10:24:41 +0200
committerMichał Lisowski2020-10-05 10:24:41 +0200
commit44f08816c7ba82c80dc35782a6f6bd012adc39c7 (patch)
tree791a66b5d9b1cbd51e44bfb68e356fde4960939d
parent39d8351b5c5723bb49d472ceebc12dc9b76cb070 (diff)
downloadaur-44f08816c7ba82c80dc35782a6f6bd012adc39c7.tar.gz
Update to 0.5.4, switch to meson build system
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD30
-rw-r--r--mime-icon-path.patch25
3 files changed, 52 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 88557bd52ac7..2062cb0e7a10 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,20 @@
pkgbase = revelation
pkgdesc = A password manager for the GNOME desktop
- pkgver = 0.5.3
+ pkgver = 0.5.4
pkgrel = 1
url = http://revelation.olasagasti.info/
arch = x86_64
license = GPL
+ makedepends = meson
+ depends = gobject-introspection
depends = gtk3
- depends = python-gobject
depends = libpwquality
+ depends = python-gobject
depends = python-pycryptodomex
- source = https://github.com/mikelolasagasti/revelation/releases/download/revelation-0.5.3/revelation-0.5.3.tar.xz
- sha256sums = 8976644b8904db179f5927ea9045c5082faefdfecf079845ca081321935bdfac
+ source = https://github.com/mikelolasagasti/revelation/releases/download/revelation-0.5.4/revelation-0.5.4.tar.xz
+ source = mime-icon-path.patch
+ sha256sums = 880a90c3c1d317fbf617809f2bb24a8752cce241248fb681812e2757c9e17fe2
+ sha256sums = 330295c0d806aaffc2e51d3fdfed663af2f8c587cc0c5afa797bb5384dda0e74
pkgname = revelation
diff --git a/PKGBUILD b/PKGBUILD
index a9b6ffef3c16..bba6d25cde39 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,28 +2,36 @@
# Contributor: Thomas Hebb <tommyhebb@gmail.com>
# Contributor: Jan de Groot <jgc@archlinux.org>
pkgname=revelation
-pkgver=0.5.3
+pkgver=0.5.4
pkgrel=1
pkgdesc="A password manager for the GNOME desktop"
arch=('x86_64')
license=('GPL')
-depends=('gtk3' 'python-gobject' 'libpwquality' 'python-pycryptodomex')
+makedepends=('meson')
+depends=('gobject-introspection' 'gtk3' 'libpwquality' 'python-gobject' 'python-pycryptodomex')
url="http://revelation.olasagasti.info/"
-source=("https://github.com/mikelolasagasti/revelation/releases/download/${pkgname}-${pkgver}/${pkgname}-${pkgver}.tar.xz")
-sha256sums=('8976644b8904db179f5927ea9045c5082faefdfecf079845ca081321935bdfac')
+source=("https://github.com/mikelolasagasti/revelation/releases/download/${pkgname}-${pkgver}/${pkgname}-${pkgver}.tar.xz"
+ 'mime-icon-path.patch')
+sha256sums=('880a90c3c1d317fbf617809f2bb24a8752cce241248fb681812e2757c9e17fe2'
+ '330295c0d806aaffc2e51d3fdfed663af2f8c587cc0c5afa797bb5384dda0e74')
+
+prepare() {
+ cd "${pkgname}-${pkgver}"
+
+ patch -p1 -i "${srcdir}/mime-icon-path.patch"
+}
build() {
cd "${pkgname}-${pkgver}"
- ./autogen.sh
- ./configure \
- --prefix=/usr \
- --disable-desktop-update \
- --disable-mime-update
- make
+
+ meson _build
+ meson configure --prefix=/usr _build
}
package() {
cd "${pkgname}-${pkgver}"
- make DESTDIR="${pkgdir}" install
+
+ cd _build
+ DESTDIR="${pkgdir}" meson install
}
diff --git a/mime-icon-path.patch b/mime-icon-path.patch
new file mode 100644
index 000000000000..a268fa7f2a75
--- /dev/null
+++ b/mime-icon-path.patch
@@ -0,0 +1,25 @@
+From b79fbacf97d2a9c5484c09242f3ed9d41250cf80 Mon Sep 17 00:00:00 2001
+From: Mikel Olasagasti Uranga <mikel@olasagasti.info>
+Date: Sun, 4 Oct 2020 16:17:03 +0200
+Subject: [PATCH] Change mime icon path
+
+---
+ data/icons/meson.build | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/data/icons/meson.build b/data/icons/meson.build
+index e7e1f29..928e678 100644
+--- a/data/icons/meson.build
++++ b/data/icons/meson.build
+@@ -19,7 +19,7 @@ endforeach
+ # Mime icons
+ install_data(
+ join_paths('48x48', 'gnome-mime-application-x-revelation.png'),
+- install_dir: join_paths(rvl_pkgdatadir, 'icons', 'hicolor', '48x48', 'mimetypes'),
++ install_dir: join_paths(rvl_datadir, 'icons', 'hicolor', '48x48', 'mimetypes'),
+ )
+
+ # Actions icons
+--
+2.26.2
+