summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Hebb2015-01-25 12:10:16 -0500
committerThomas Hebb2015-01-25 12:10:16 -0500
commit5e608762edec411024ec96a7290e21df6b44ca60 (patch)
treee2e9f589d9754ed9b98bfc3729559ec1480ae4ab
parent1197a872d0da30327cd7861e1c3293f60ea778ad (diff)
downloadaur-5e608762edec411024ec96a7290e21df6b44ca60.tar.gz
Split build() into build() and package()
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ef4a4b415bfa..969a28fce8ee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = revelation
pkgdesc = A password manager for the GNOME desktop
pkgver = 0.4.14
- pkgrel = 3
+ pkgrel = 4
url = http://revelation.olasagasti.info/
install = revelation.install
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 8abbcb96c5c4..616d818676de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Jan de Groot <jgc@archlinux.org>
pkgname=revelation
pkgver=0.4.14
-pkgrel=3
+pkgrel=4
pkgdesc="A password manager for the GNOME desktop"
arch=('i686' 'x86_64')
license=('GPL')
@@ -32,13 +32,17 @@ build() {
--disable-mime-update --disable-desktop-update \
--with-python-include=/usr/include/python2.7
make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
make GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1 DESTDIR="${pkgdir}" install
sed -i "s|#!/usr/bin/\(env \)\?python$|#!/usr/bin/\1python2|" \
$pkgdir/usr/bin/revelation \
$pkgdir/usr/lib/python2.7/site-packages/revelation/bundle/PBKDFv2.py
-
install -m755 -d "${pkgdir}/usr/share/gconf/schemas"
gconf-merge-schema "${pkgdir}/usr/share/gconf/schemas/${pkgname}.schemas" --domain revelation ${pkgdir}/etc/gconf/schemas/*.schemas || return 1
rm -f ${pkgdir}/etc/gconf/schemas/*.schemas