summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordanitool2016-10-07 11:25:26 +0200
committerdanitool2016-10-07 11:25:26 +0200
commit83dbb1a43db336580f2942a549fb7737f60674b6 (patch)
tree352d5bc359e0d5b2a2224081162ff8c1b1bd5138
downloadaur-83dbb1a43db336580f2942a549fb7737f60674b6.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
-rw-r--r--query-fix.patch11
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e595a2dc52cd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Fri Oct 7 09:25:08 UTC 2016
+pkgbase = revoco
+ pkgdesc = Change the wheel behaviour of Logitech's MX-Revolution mouse.
+ pkgver = 0.6
+ pkgrel = 2
+ url = https://github.com/sebastien/revoco
+ arch = i686
+ arch = x86_64
+ conflicts = revoco2
+ source = http://downloads.sourceforge.net/project/revoco/revoco-0.6.tar.bz2
+ source = query-fix.patch
+ md5sums = 97da18a988893a03098bfea6f2525686
+ md5sums = 0699b052b8e555e937e465f588f7300f
+
+pkgname = revoco
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..34f4b7cc3f05
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Contributor: Henrik Nymann Jensen <h@henriknj.dk>
+
+pkgname=revoco
+pkgver=0.6
+pkgrel=2
+pkgdesc="Change the wheel behaviour of Logitech's MX-Revolution mouse."
+arch=('i686' 'x86_64')
+url="https://github.com/sebastien/revoco"
+license=()
+conflicts=('revoco2')
+source=(http://downloads.sourceforge.net/project/revoco/$pkgname-$pkgver.tar.bz2
+query-fix.patch)
+md5sums=('97da18a988893a03098bfea6f2525686'
+ '0699b052b8e555e937e465f588f7300f')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ patch -p1 < ../query-fix.patch
+ make || return 1
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ install -D -m755 revoco $pkgdir/usr/bin/revoco
+}
diff --git a/query-fix.patch b/query-fix.patch
new file mode 100644
index 000000000000..eeab34b36f82
--- /dev/null
+++ b/query-fix.patch
@@ -0,0 +1,11 @@
+--- a/revoco.c 2013-08-26 14:32:57.365967373 +0200
++++ b/revoco.c 2013-08-26 14:32:43.399300460 +0200
+@@ -280,7 +280,7 @@
+ query_report(fd, 0x10, res, 6);
+
+ if ((res[0] != 0x01 || res[1] != 0x81 || res[2] != 0xb1) &&
+- (res[0] != 0x02 || res[1] != 0x81 || (res[2] != 0x0d && res[2] != 0x08)))
++ ((res[0] != 0x01 && res[0] != 0x02) || res[1] != 0x81 || (res[2] != 0x0d && res[2] != 0x08)))
+ {
+ printf("bad answer (%02x %02x %02x...)\n", res[0], res[1], res[2]);
+ return 0;