summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorÓscar García Amor2021-05-04 12:40:53 +0200
committerÓscar García Amor2021-05-04 12:40:53 +0200
commite9325dd245dda783bcd129aeeab46941a55b11dc (patch)
tree69fe5b7b72f884e0595bf8708b1814cf20f82642
downloadaur-e9325dd245dda783bcd129aeeab46941a55b11dc.tar.gz
Initial upload: revolt 2020.09.30-1
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD25
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2f227b72a48b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = revolt
+ pkgdesc = Better desktop integration for Riot.im (not only) for GNOME
+ pkgver = 2020.09.30
+ pkgrel = 1
+ url = https://github.com/aperezdc/revolt
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = GPL3
+ depends = python-gobject
+ depends = webkit2gtk
+ options = !strip
+ options = !emptydirs
+ source = revolt-2020.09.30.tar.gz::https://github.com/aperezdc/revolt/archive/0aca6c862fdcb262089bacfa3c43f8ff8ceb1f83.tar.gz
+ sha256sums = 27c7b01766cdfc35db64af67c59f165b980417ce7d1a37da636a84a21f6a7550
+
+pkgname = revolt
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8effdfd0ec13
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: "Amhairghin" Oscar Garcia Amor (https://ogarcia.me)
+
+_commit='0aca6c862fdcb262089bacfa3c43f8ff8ceb1f83'
+pkgname=revolt
+pkgver=2020.09.30
+pkgrel=1
+pkgdesc='Better desktop integration for Riot.im (not only) for GNOME'
+arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
+url='https://github.com/aperezdc/revolt'
+license=('GPL3')
+depends=('python-gobject' 'webkit2gtk')
+options=('!strip' '!emptydirs')
+source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/aperezdc/${pkgname}/archive/${_commit}.tar.gz")
+sha256sums=('27c7b01766cdfc35db64af67c59f165b980417ce7d1a37da636a84a21f6a7550')
+
+build() {
+ cd "${pkgname}-${_commit}"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${pkgname}-${_commit}"
+ make install DESTDIR="${pkgdir}"
+}