summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2020-07-18 19:20:30 +0200
committerChristopher Arndt2020-07-18 19:20:30 +0200
commit1ff06fa5476ba1e0a78f4291ae805480a6ce5974 (patch)
treeec4d345305803060622406e009fe142b9e6196ce
parentb7eedabd8d5a96a71ad63e10203a01a942c23cfd (diff)
downloadaur-1ff06fa5476ba1e0a78f4291ae805480a6ce5974.tar.gz
Add patch for missing include
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD13
-rw-r--r--rezonateur-stdexcept.diff11
4 files changed, 25 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1b76d34d5a60..cd90924f299e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = rezonateur-git
pkgdesc = A virtual-analog 3-band resonator audio effect LV2 and VST2 plugin and JACK client (git version)
- pkgver = 0.1.0.r3.ge117125
+ pkgver = 0.1.0.r5.g82b7313
pkgrel = 1
url = https://github.com/jpcima/rezonateur
arch = i686
@@ -18,8 +18,10 @@ pkgbase = rezonateur-git
conflicts = rezonateur
source = rezonateur::git+https://github.com/jpcima/rezonateur.git
source = dpf::git+https://github.com/DISTRHO/DPF.git
+ source = rezonateur-stdexcept.diff
md5sums = SKIP
md5sums = SKIP
+ md5sums = 5ede4924e37ac26ccf8048312210aafc
pkgname = rezonateur-git
diff --git a/.gitignore b/.gitignore
index af66072769f4..d47d1a6b30e1 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,5 +3,6 @@ rezonateur/
pkg/
src/
.AURINFO
-rezonateur-git-*.tar.xz
+rezonateur-git-*.pkg.tar.xz
+rezonateur-git-*.pkg.tar.zst
rezonateur-git-*.src.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index dff322c05a15..667fb4839681 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=rezonateur
pkgname="${_pkgname}-git"
-pkgver=0.1.0.r3.ge117125
+pkgver=0.1.0.r5.g82b7313
pkgrel=1
pkgdesc="A virtual-analog 3-band resonator audio effect LV2 and VST2 plugin and JACK client (git version)"
arch=('i686' 'x86_64')
@@ -15,8 +15,11 @@ groups=('pro-audio' 'lv2-plugins' 'vst-plugins')
provides=("${_pkgname}" "${_pkgname}=${pkgver//.r*/}")
conflicts=("${_pkgname}")
source=("${_pkgname}::git+https://github.com/jpcima/${_pkgname}.git"
- 'dpf::git+https://github.com/DISTRHO/DPF.git')
-md5sums=('SKIP' 'SKIP')
+ 'dpf::git+https://github.com/DISTRHO/DPF.git'
+ 'rezonateur-stdexcept.diff')
+md5sums=('SKIP'
+ 'SKIP'
+ '5ede4924e37ac26ccf8048312210aafc')
pkgver() {
cd "${srcdir}/${_pkgname}"
@@ -32,8 +35,10 @@ prepare() {
git config submodule.dpf.url "${srcdir}/dpf"
git submodule update
+ patch -N -r - -p 1 -i "${srcdir}"/rezonateur-stdexcept.diff || :
+
cd dpf
- patch -N -r - -p 1 -i ../resources/patch/DPF-bypass.patch || return 0
+ patch -N -r - -p 1 -i ../resources/patch/DPF-bypass.patch || :
}
build() {
diff --git a/rezonateur-stdexcept.diff b/rezonateur-stdexcept.diff
new file mode 100644
index 000000000000..c45b27395031
--- /dev/null
+++ b/rezonateur-stdexcept.diff
@@ -0,0 +1,11 @@
+diff --git a/plugins/rezonateur/components/KnobSkin.cpp b/plugins/rezonateur/components/KnobSkin.cpp
+index 9fe4500..cd4a76c 100644
+--- a/plugins/rezonateur/components/KnobSkin.cpp
++++ b/plugins/rezonateur/components/KnobSkin.cpp
+@@ -1,5 +1,6 @@
+ #include "KnobSkin.hpp"
+ #include <cassert>
++#include <stdexcept>
+
+ KnobSkin::KnobSkin(const char *pngData, unsigned pngSize, unsigned imageCount)
+ : fSurface(cairo_image_surface_create_from_png_data(pngData, pngSize)),