summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2020-07-19 17:44:26 +0200
committerChristopher Arndt2020-07-19 17:44:26 +0200
commit6fb532606ab45ddffbf7b09d916d525947f10a53 (patch)
treecf9fc20fa91ee388cae4ab348a4205165a4f2568
parent1ff06fa5476ba1e0a78f4291ae805480a6ce5974 (diff)
downloadaur-6fb532606ab45ddffbf7b09d916d525947f10a53.tar.gz
Remove patch again (fixed upstream)
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
-rw-r--r--rezonateur-stdexcept.diff11
3 files changed, 4 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cd90924f299e..32e754c7b9e9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = rezonateur-git
pkgdesc = A virtual-analog 3-band resonator audio effect LV2 and VST2 plugin and JACK client (git version)
- pkgver = 0.1.0.r5.g82b7313
+ pkgver = 0.1.0.r6.g58ccec5
pkgrel = 1
url = https://github.com/jpcima/rezonateur
arch = i686
@@ -18,10 +18,8 @@ pkgbase = rezonateur-git
conflicts = rezonateur
source = rezonateur::git+https://github.com/jpcima/rezonateur.git
source = dpf::git+https://github.com/DISTRHO/DPF.git
- source = rezonateur-stdexcept.diff
md5sums = SKIP
md5sums = SKIP
- md5sums = 5ede4924e37ac26ccf8048312210aafc
pkgname = rezonateur-git
diff --git a/PKGBUILD b/PKGBUILD
index 667fb4839681..6048867aef0b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=rezonateur
pkgname="${_pkgname}-git"
-pkgver=0.1.0.r5.g82b7313
+pkgver=0.1.0.r6.g58ccec5
pkgrel=1
pkgdesc="A virtual-analog 3-band resonator audio effect LV2 and VST2 plugin and JACK client (git version)"
arch=('i686' 'x86_64')
@@ -15,11 +15,9 @@ groups=('pro-audio' 'lv2-plugins' 'vst-plugins')
provides=("${_pkgname}" "${_pkgname}=${pkgver//.r*/}")
conflicts=("${_pkgname}")
source=("${_pkgname}::git+https://github.com/jpcima/${_pkgname}.git"
- 'dpf::git+https://github.com/DISTRHO/DPF.git'
- 'rezonateur-stdexcept.diff')
+ 'dpf::git+https://github.com/DISTRHO/DPF.git')
md5sums=('SKIP'
- 'SKIP'
- '5ede4924e37ac26ccf8048312210aafc')
+ 'SKIP')
pkgver() {
cd "${srcdir}/${_pkgname}"
@@ -35,8 +33,6 @@ prepare() {
git config submodule.dpf.url "${srcdir}/dpf"
git submodule update
- patch -N -r - -p 1 -i "${srcdir}"/rezonateur-stdexcept.diff || :
-
cd dpf
patch -N -r - -p 1 -i ../resources/patch/DPF-bypass.patch || :
}
diff --git a/rezonateur-stdexcept.diff b/rezonateur-stdexcept.diff
deleted file mode 100644
index c45b27395031..000000000000
--- a/rezonateur-stdexcept.diff
+++ /dev/null
@@ -1,11 +0,0 @@
-diff --git a/plugins/rezonateur/components/KnobSkin.cpp b/plugins/rezonateur/components/KnobSkin.cpp
-index 9fe4500..cd4a76c 100644
---- a/plugins/rezonateur/components/KnobSkin.cpp
-+++ b/plugins/rezonateur/components/KnobSkin.cpp
-@@ -1,5 +1,6 @@
- #include "KnobSkin.hpp"
- #include <cassert>
-+#include <stdexcept>
-
- KnobSkin::KnobSkin(const char *pngData, unsigned pngSize, unsigned imageCount)
- : fSurface(cairo_image_surface_create_from_png_data(pngData, pngSize)),