summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorManuel Coenen2019-09-02 11:52:57 +0200
committerManuel Coenen2019-09-02 11:52:57 +0200
commit2788236ddb9a57d3ae1dbe2ba8fcc0674e58b30a (patch)
tree568c1fc245351d511eb78e34940104a473b74378
parenta45b429c6ca75c13758280d4860d62f53d06a776 (diff)
downloadaur-2788236ddb9a57d3ae1dbe2ba8fcc0674e58b30a.tar.gz
Convert to a package built from source
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD23
2 files changed, 18 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fc8cb1b68dae..09ef38ee98de 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,22 +3,13 @@ pkgbase = rfm
pkgver = 1.1.0
pkgrel = 1
url = https://github.com/wilriker/rfm
- arch = x86_64
- arch = arm
- arch = armv6h
- arch = armv7h
- arch = aarch64
+ arch = any
license = MIT
- source_x86_64 = https://github.com/wilriker/rfm/releases/download/v1.1.0/rfm-linux_amd64.tgz
- md5sums_x86_64 = SKIP
- source_arm = https://github.com/wilriker/rfm/releases/download/v1.1.0/rfm-linux_arm.tgz
- md5sums_arm = SKIP
- source_armv6h = https://github.com/wilriker/rfm/releases/download/v1.1.0/rfm-linux_arm.tgz
- md5sums_armv6h = SKIP
- source_armv7h = https://github.com/wilriker/rfm/releases/download/v1.1.0/rfm-linux_arm.tgz
- md5sums_armv7h = SKIP
- source_aarch64 = https://github.com/wilriker/rfm/releases/download/v1.1.0/rfm-linux_arm64.tgz
- md5sums_aarch64 = SKIP
+ makedepends = go
+ provides = rfm
+ conflicts = rfm
+ source = https://github.com/wilriker/rfm/archive/v1.1.0.tar.gz
+ sha256sums = f282d115ac41fedf1c7a76c81cc06a4a610d1617a925ac40d0401511cbea43fa
pkgname = rfm
diff --git a/PKGBUILD b/PKGBUILD
index 93b99874310e..78841bbc4af2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,21 +3,22 @@ pkgname=rfm
pkgver=1.1.0
pkgrel=1
pkgdesc="Command-line interface to perform file management on RepRapFirmware based devices."
-arch=('x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
+arch=('any')
+makedepends=('go')
url="https://github.com/wilriker/rfm"
license=('MIT')
-source_x86_64=("https://github.com/wilriker/rfm/releases/download/v${pkgver//_/-}/rfm-linux_amd64.tgz")
-source_arm=("https://github.com/wilriker/rfm/releases/download/v${pkgver//_/-}/rfm-linux_arm.tgz")
-source_armv6h=("https://github.com/wilriker/rfm/releases/download/v${pkgver//_/-}/rfm-linux_arm.tgz")
-source_armv7h=("https://github.com/wilriker/rfm/releases/download/v${pkgver//_/-}/rfm-linux_arm.tgz")
-source_aarch64=("https://github.com/wilriker/rfm/releases/download/v${pkgver//_/-}/rfm-linux_arm64.tgz")
-md5sums_x86_64=('SKIP')
-md5sums_arm=('SKIP')
-md5sums_armv6h=('SKIP')
-md5sums_armv7h=('SKIP')
-md5sums_aarch64=('SKIP')
+provides=('rfm')
+conflicts=('rfm')
+source=("https://github.com/wilriker/rfm/archive/v${pkgver//_/-}.tar.gz")
+sha256sums=('f282d115ac41fedf1c7a76c81cc06a4a610d1617a925ac40d0401511cbea43fa')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ go build -o rfm cmd/rfm/main.go
+}
package() {
+ cd "${pkgname}-${pkgver}"
install -Dm 755 rfm "${pkgdir}/usr/bin/rfm"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}