summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBartłomiej Piotrowski2018-01-05 18:00:35 +0100
committerBartłomiej Piotrowski2018-01-05 18:00:35 +0100
commited6c0eafa9c4b735b4d3f560dddfcbc6bda1a4ae (patch)
tree4fc3cb5539a9620b9d37a60418c4d767a6fad2b2
downloadaur-ed6c0eafa9c4b735b4d3f560dddfcbc6bda1a4ae.tar.gz
Import from official repositories
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD34
-rwxr-xr-xrftg.desktop17
-rw-r--r--rftg.svg91
4 files changed, 159 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1ef72f504067
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = rftg
+ pkgdesc = Singleplayer and online implementation of the card game Race for the Galaxy by Tom Lehman.
+ pkgver = 0.9.5
+ pkgrel = 1
+ url = http://keldon.net/rftg/
+ arch = x86_64
+ license = GPL
+ depends = gtk2
+ source = https://github.com/bnordli/rftg/archive/0.9.5.tar.gz
+ source = rftg.desktop
+ source = rftg.svg
+ md5sums = 9cd1154ba43651890bea4dc35b1678fc
+ md5sums = f2c1a72b0fbf191e564069dfe61d50c4
+ md5sums = e0ad78078729229ad1414276348b7d98
+
+pkgname = rftg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bc4081b08cb6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: schuay <jakob.gruber@gmail.com>
+# Contributor: mk47at
+
+pkgname=rftg
+pkgver=0.9.5
+_pkgver=0.9.4
+pkgrel=1
+pkgdesc="Singleplayer and online implementation of the card game Race for the Galaxy by Tom Lehman."
+arch=('x86_64')
+url="http://keldon.net/rftg/"
+license=('GPL')
+depends=('gtk2')
+source=("https://github.com/bnordli/rftg/archive/${pkgver}.tar.gz"
+ "$pkgname.desktop"
+ "rftg.svg")
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver/src"
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver/src"
+
+ make DESTDIR="$pkgdir/" install
+ install -D -m644 "$srcdir/$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -D -m644 "$srcdir/$pkgname.svg" "$pkgdir/usr/share/rftg/$pkgname.svg"
+}
+
+md5sums=('9cd1154ba43651890bea4dc35b1678fc'
+ 'f2c1a72b0fbf191e564069dfe61d50c4'
+ 'e0ad78078729229ad1414276348b7d98')
diff --git a/rftg.desktop b/rftg.desktop
new file mode 100755
index 000000000000..60048d7f85bb
--- /dev/null
+++ b/rftg.desktop
@@ -0,0 +1,17 @@
+[Desktop Entry]
+Encoding=UTF-8
+Version=1.0
+Name=Race for the Galaxy
+
+Comment=Singleplayer and online implementation of the card game Race for the Galaxy by Tom Lehman.
+
+Exec=rftg
+FilePattern=rftg;
+TryExec=rftg
+Terminal=false
+Icon=/usr/share/rftg/rftg.svg
+
+StartupNotify=false
+
+Type=Application
+Categories=Game;StrategyGame
diff --git a/rftg.svg b/rftg.svg
new file mode 100644
index 000000000000..2699c661debc
--- /dev/null
+++ b/rftg.svg
@@ -0,0 +1,91 @@
+<?xml version="1.0" encoding="UTF-8" standalone="no"?>
+<!-- Created with Inkscape (http://www.inkscape.org/) -->
+<svg
+ xmlns:dc="http://purl.org/dc/elements/1.1/"
+ xmlns:cc="http://creativecommons.org/ns#"
+ xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
+ xmlns:svg="http://www.w3.org/2000/svg"
+ xmlns="http://www.w3.org/2000/svg"
+ xmlns:sodipodi="http://sodipodi.sourceforge.net/DTD/sodipodi-0.dtd"
+ xmlns:inkscape="http://www.inkscape.org/namespaces/inkscape"
+ width="70.690163"
+ height="70.690186"
+ id="svg2"
+ sodipodi:version="0.32"
+ inkscape:version="0.46"
+ sodipodi:docname="rftg.svg"
+ inkscape:output_extension="org.inkscape.output.svg.inkscape"
+ version="1.0">
+ <defs
+ id="defs4">
+ <inkscape:perspective
+ sodipodi:type="inkscape:persp3d"
+ inkscape:vp_x="0 : 526.18109 : 1"
+ inkscape:vp_y="0 : 1000 : 0"
+ inkscape:vp_z="744.09448 : 526.18109 : 1"
+ inkscape:persp3d-origin="372.04724 : 350.78739 : 1"
+ id="perspective10" />
+ <inkscape:perspective
+ id="perspective2449"
+ inkscape:persp3d-origin="372.04724 : 350.78739 : 1"
+ inkscape:vp_z="744.09448 : 526.18109 : 1"
+ inkscape:vp_y="0 : 1000 : 0"
+ inkscape:vp_x="0 : 526.18109 : 1"
+ sodipodi:type="inkscape:persp3d" />
+ </defs>
+ <sodipodi:namedview
+ id="base"
+ pagecolor="#ffffff"
+ bordercolor="#666666"
+ borderopacity="1.0"
+ inkscape:pageopacity="0.0"
+ inkscape:pageshadow="2"
+ inkscape:zoom="8.0350617"
+ inkscape:cx="35.345081"
+ inkscape:cy="35.345093"
+ inkscape:document-units="px"
+ inkscape:current-layer="layer1"
+ showgrid="false"
+ inkscape:window-width="1272"
+ inkscape:window-height="783"
+ inkscape:window-x="0"
+ inkscape:window-y="0" />
+ <metadata
+ id="metadata7">
+ <rdf:RDF>
+ <cc:Work
+ rdf:about="">
+ <dc:format>image/svg+xml</dc:format>
+ <dc:type
+ rdf:resource="http://purl.org/dc/dcmitype/StillImage" />
+ </cc:Work>
+ </rdf:RDF>
+ </metadata>
+ <g
+ inkscape:label="Ebene 1"
+ inkscape:groupmode="layer"
+ id="layer1"
+ transform="translate(1869.4689,200.8101)">
+ <path
+ sodipodi:type="arc"
+ style="opacity:1;fill:#ffffff;fill-opacity:1;stroke:#e01d2b;stroke-width:19.84541321;stroke-linecap:butt;stroke-linejoin:miter;stroke-miterlimit:4;stroke-dasharray:none;stroke-dashoffset:0;stroke-opacity:1"
+ id="path2383"
+ sodipodi:cx="357.14285"
+ sodipodi:cy="348.07648"
+ sodipodi:rx="200"
+ sodipodi:ry="181.42857"
+ d="M 557.14285,348.07648 A 200,181.42857 0 1 1 157.14285,348.07648 A 200,181.42857 0 1 1 557.14285,348.07648 z"
+ transform="matrix(0.1679754,0,0,0.1851698,-1894.115,-229.91826)" />
+ <text
+ xml:space="preserve"
+ style="font-size:12px;font-style:normal;font-weight:normal;fill:#e01d2b;fill-opacity:1;stroke:none;stroke-width:1px;stroke-linecap:butt;stroke-linejoin:miter;stroke-opacity:1;font-family:Bitstream Vera Sans"
+ x="-1859.1549"
+ y="-155.03212"
+ id="text3225"><tspan
+ sodipodi:role="line"
+ id="tspan3227"
+ x="-1859.1549"
+ y="-155.03212"
+ style="font-size:32px;fill:#e01d2b;fill-opacity:1">+2</tspan></text>
+ </g>
+</svg>