summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCelestialWalrus2015-08-21 08:29:07 -0400
committerCelestialWalrus2015-08-21 08:29:07 -0400
commit0c33e3bc3d2909581dc6fcaa3eeda093e403a3af (patch)
tree82e915cab0284710fb88db1f2e43c996f501d722
downloadaur-0c33e3bc3d2909581dc6fcaa3eeda093e403a3af.tar.gz
1.3.3
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD31
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7590fcef8749
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = rgain
+ pkgdesc = Modules to read, write and calculate Replay Gain
+ pkgver = 1.3.3
+ pkgrel = 1
+ url = https://bitbucket.org/fk/rgain
+ arch = any
+ license = GPL
+ makedepends = python2-docutils
+ depends = python2
+ depends = mutagen
+ depends = gstreamer
+ depends = pygobject2-devel
+ depends = gst-plugins-good
+ optdepends = gst-plugins-bad
+ optdepends = gst-plugins-ugly
+ options = !emptydirs
+ source = https://bitbucket.org/fk/rgain/get/1.3.3.tar.bz2
+ md5sums = 8ab585c0d0051cc86675d86750b3f8a6
+
+pkgname = rgain
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a1985202a6bb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Original PKGBUILD Author: Bruno Jacquet <maxijac@free.fr>
+# Maintainer: CelestialWalrus <aur@celestial.cf>
+pkgname=rgain
+pkgver=1.3.3
+_dirname='fk-'$pkgname'-ee516a7bec19'
+pkgrel=1
+pkgdesc="Modules to read, write and calculate Replay Gain"
+arch=('any')
+url="https://bitbucket.org/fk/rgain"
+license=('GPL')
+groups=()
+#Actually we get a traceback when gst-plugins-good is not installed
+depends=('python2' 'mutagen' 'gstreamer' 'pygobject2-devel' 'gst-plugins-good')
+makedepends=('python2-docutils')
+optdepends=('gst-plugins-bad' 'gst-plugins-ugly')
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+install=
+source=('https://bitbucket.org/fk/rgain/get/'${pkgver}'.tar.bz2')
+md5sums=('8ab585c0d0051cc86675d86750b3f8a6')
+
+package() {
+ cd "$srcdir/$_dirname"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+ install -m755 -d "${pkgdir}/usr/share/man/man1"
+ install -m644 build/man/collectiongain.1 "${pkgdir}/usr/share/man/man1/"
+ install -m644 build/man/replaygain.1 "${pkgdir}/usr/share/man/man1/"
+}