summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDylan Delgado2021-02-02 15:07:14 -0500
committerDylan Delgado2021-02-02 15:07:14 -0500
commit38243343723c14710116479b21635173f07c3fce (patch)
treef071cdfc99debd0d401f1798f304490714556dd0
downloadaur-38243343723c14710116479b21635173f07c3fce.tar.gz
Initial release
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD53
-rw-r--r--make.patch12
3 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..26e010921c68
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = rgepp
+ pkgdesc = Template-based C++ class library for solving renormaliztion group equations in quantum field theory
+ pkgver = r24.1d9b740
+ pkgrel = 1
+ url = www.github.com/Herren/RGEpp
+ arch = x86_64
+ license = MIT
+ makedepends = clang
+ depends = boost
+ depends = eigen
+ source = git://github.com/Herren/RGEpp.git
+ source = make.patch
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = rgepp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0d3fc1703eb5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+#Maintainer: Dylan Delgado <dylan1496@live.com>
+
+pkgname=rgepp
+_pkgname=RGEpp
+pkgver=r24.1d9b740
+pkgrel=1
+pkgdesc="Template-based C++ class library for solving renormaliztion group equations in quantum field theory"
+url="www.github.com/Herren/RGEpp"
+license=("MIT")
+arch=('x86_64')
+depends=('boost' 'eigen')
+makedepends=('clang')
+
+source=("git://github.com/Herren/RGEpp.git"
+"make.patch")
+md5sums=("SKIP"
+"SKIP")
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+cd "${srcdir}/${_pkgname}"
+patch -l -p1 < ../make.patch
+}
+
+build () {
+cd "${srcdir}/${_pkgname}"
+make
+make sm_example
+make nsm_example
+make numssm_example
+make thdm_example
+make running_plot
+}
+
+package() {
+mkdir -p "${pkgdir}/usr/include/rgepp/"
+cd "${srcdir}/${_pkgname}/examples"
+install -Dm755 sm_example "${pkgdir}/usr/bin/sm_example"
+install -Dm755 nsm_example "${pkgdir}/usr/bin/nsm_example"
+install -Dm755 numssm_example "${pkgdir}/usr/bin/numssm_example"
+install -Dm755 thdm_example "${pkgdir}/usr/bin/thdm_example"
+install -Dm755 running_plot "${pkgdir}/usr/bin/running_plot"
+for i in include models
+ do
+ cd "${srcdir}/${_pkgname}/${i}"
+ echo "Copying from $PWD"
+ install -Dm644 *.h "${pkgdir}/usr/include/rgepp/"
+done
+} \ No newline at end of file
diff --git a/make.patch b/make.patch
new file mode 100644
index 000000000000..560efe968760
--- /dev/null
+++ b/make.patch
@@ -0,0 +1,12 @@
+diff --unified --recursive --text RGEpp/makefile RGEpp-1/makefile
+--- RGEpp/makefile 2021-02-02 13:20:16.740084619 -0500
++++ RGEpp-1/makefile 2021-02-02 13:23:40.616419761 -0500
+@@ -1,6 +1,6 @@
+ CC = clang++
+-ODEINTPATH = odeint/include
+-EIGENPATH = eigen
++ODEINTPATH = /usr/include/boost/numeric/odeint/
++EIGENPATH = /usr/include/eigen3/
+ RGEPPPATH = $(PWD)
+ FLAVOUROBJ = src/ckm.o src/pmns.o
+ FLAGS = -std=c++11 -I $(ODEINTPATH) -I $(EIGENPATH) -I $(RGEPPPATH)/include -I $(RGEPPPATH)/models