summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorburdoto2023-05-07 22:52:18 +0200
committerburdoto2023-05-07 22:52:18 +0200
commit36b0b80313fbab88b378644e40b7d24b7ca88fc9 (patch)
tree5b5acdf5dfdbc951356b9cdf6bb00c3cf85a6f1e
parent14e1681ce4a12bee5d3c0745f6daecda892e45e5 (diff)
downloadaur-36b0b80313fbab88b378644e40b7d24b7ca88fc9.tar.gz
publish single file only
-rw-r--r--PKGBUILD4
-rwxr-xr-xpublish.sh5
-rw-r--r--rgx.csproj2
3 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 917efb563f64..18b96ba2324e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,9 +14,9 @@ md5sums=('SKIP')
build() {
cd "$srcdir/rgx"
- dotnet build -c Release --sc --use-current-runtime -p:PublishSingleFile=true
+ dotnet publish -c Release --use-current-runtime
}
package() {
- install -Dm755 "$srcdir/rgx/bin/Release/net6.0/linux-x64/rgx" "$pkgdir/usr/bin/rgx"
+ install -Dm755 "$srcdir/rgx/bin/Release/net6.0/linux-x64/publish/rgx" "$pkgdir/usr/bin/rgx"
}
diff --git a/publish.sh b/publish.sh
index a79690666d37..4375c1b5d117 100755
--- a/publish.sh
+++ b/publish.sh
@@ -4,7 +4,7 @@ set -e # exit on error
# make prebuilt executable
dotnet clean
-dotnet build -c Release --sc --use-current-runtime -p:PublishSingleFile=true
+dotnet publish -c Release --use-current-runtime
# update SRCINFO
git clean -f
@@ -12,6 +12,9 @@ git reset --hard
makepkg --printsrcinfo > .SRCINFO
(git add .SRCINFO && git commit -m "SRCINFO" && git push) || true
+# verify that makepkg works
+makepkg -C --noconfirm
+
# push to aur
if [ -z "$(git remote | grep aur)" ]; then
git remote add aur ssh://aur@aur.archlinux.org/rgx-git.git
diff --git a/rgx.csproj b/rgx.csproj
index b61ffa39253d..acc3f1e12ff3 100644
--- a/rgx.csproj
+++ b/rgx.csproj
@@ -9,6 +9,8 @@
<Company>comroid</Company>
<AssemblyVersion>0.1.0</AssemblyVersion>
<FileVersion>0.10</FileVersion>
+ <PublishSingleFile>true</PublishSingleFile>
+ <SelfContained>true</SelfContained>
<LibCommonPath>..\csapi\common\common.csproj</LibCommonPath>
</PropertyGroup>