summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Epaneshnikov2020-12-04 01:45:18 +0300
committerAlexander Epaneshnikov2020-12-04 01:45:18 +0300
commita34d024ba2fcb78eccb6f1852da4880454b0316d (patch)
treeabce31966907fe477648165f56c306f31f8fec3e
parentb4073ca7ee4a35dbba3b5e6264d492133519cf8d (diff)
downloadaur-a34d024ba2fcb78eccb6f1852da4880454b0316d.tar.gz
upgpkg: rhvoice 1.2.3-2
speech-dispatcher-0.10.2-1 rebuild clarify licence
-rw-r--r--.SRCINFO6
-rwxr-xr-xPKGBUILD11
2 files changed, 13 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index def587d8a662..df38e19307bc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,14 @@
pkgbase = rhvoice
pkgdesc = Free and open source speech synthesizer for Russian and other languages
pkgver = 1.2.3
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Olga-Yakovleva/RHVoice
arch = x86_64
license = GPL3
+ license = custom
+ license = custom:by-nc-nd-4.0
+ license = custom:by-nc-sa-4.0
+ license = custom:by-sa-4.0
makedepends = scons
makedepends = portaudio
makedepends = libao
diff --git a/PKGBUILD b/PKGBUILD
index 9ce44d3bb4a0..eeeb25117c94 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,11 +2,12 @@
pkgname=rhvoice
pkgver=1.2.3
-pkgrel=1
+pkgrel=2
pkgdesc="Free and open source speech synthesizer for Russian and other languages"
arch=('x86_64')
url="https://github.com/Olga-Yakovleva/RHVoice"
-license=('GPL3')
+license=('GPL3' 'custom' 'custom:by-nc-nd-4.0' 'custom:by-nc-sa-4.0'
+ 'custom:by-sa-4.0')
depends=('speech-dispatcher' 'libpulse')
makedepends=('scons' 'portaudio' 'libao')
optdepends=('portaudio: for portaudio backend'
@@ -23,8 +24,12 @@ build() {
package() {
cd "$srcdir/RHVoice-$pkgver"
- mkdir -p "${pkgdir}/usr/lib/speech-dispatcher-modules"
+ mkdir -pv "${pkgdir}/usr/lib/speech-dispatcher-modules"
scons install DESTDIR="${pkgdir}" prefix="/usr" sysconfdir="/etc" \
CPPFLAGS="$CPPFLAGS" CCFLAGS="$CFLAGS" LINKFLAGS="$LDFLAGS"
ln -s "/usr/bin/sd_rhvoice" "${pkgdir}/usr/lib/speech-dispatcher-modules/sd_rhvoice"
+ install -Dm0644 LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm0644 licenses/by-nc-nd-4.0.txt "${pkgdir}/usr/share/licenses/${pkgname}/by-nc-nd-4.0"
+ install -Dm0644 licenses/by-nc-sa-4.0.txt "${pkgdir}/usr/share/licenses/${pkgname}/by-nc-sa-4.0"
+ install -Dm0644 licenses/by-sa-4.0.txt "${pkgdir}/usr/share/licenses/${pkgname}/by-sa-4.0"
}