summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Epaneshnikov2021-07-20 18:39:54 +0300
committerAlexander Epaneshnikov2021-07-20 18:39:54 +0300
commit8b2f0567ec9e364acad1a1b8b84bc25ccd6e85ff (patch)
treedd3f21615abc9ffdc0e5783158ac9dc010f35510
parent7befdac5d1c46c6cfe6c13120aaa65da22351729 (diff)
downloadaur-8b2f0567ec9e364acad1a1b8b84bc25ccd6e85ff.tar.gz
upgpkg: rhvoice-git 1.4.2.r1.8edead19-1
improve pkgbuild, add new submodules.
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore1
-rwxr-xr-xPKGBUILD15
3 files changed, 13 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 30a362af466f..0f6f03d6bf30 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = rhvoice-git
pkgdesc = Free and open source speech synthesizer for Russian and other languages. (development version)
- pkgver = 1.2.4.r66.87e2514
+ pkgver = 1.4.2.r1.8edead19
pkgrel = 1
url = https://github.com/RHVoice/RHVoice
arch = x86_64
@@ -27,6 +27,8 @@ pkgbase = rhvoice-git
source = git+https://github.com/RHVoice/evgeniy-eng.git
source = git+https://github.com/rhvoice/aleksandr-hq-rus.git
source = git+https://github.com/rhvoice/yuriy-rus.git
+ source = git+https://github.com/rhvoice/volodymyr-ukr.git
+ md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
diff --git a/.gitignore b/.gitignore
index 3c294e0a6c98..6660594d016d 100644
--- a/.gitignore
+++ b/.gitignore
@@ -4,3 +4,4 @@ evgeniy-rus/
evgeniy-eng/
aleksandr-hq-rus/
yuriy-rus/
+volodymyr-ukr/
diff --git a/PKGBUILD b/PKGBUILD
index 01134717f1cd..b9dfe733f5df 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: der_fenix <derfenix@gmail.com>
pkgname=rhvoice-git
-pkgver=1.2.4.r66.87e2514
+pkgver=1.4.2.r1.8edead19
pkgrel=1
pkgdesc="Free and open source speech synthesizer for Russian and other languages. (development version)"
arch=('x86_64')
@@ -23,27 +23,30 @@ source=(${pkgname%-git}::'git+https://github.com/RHVoice/RHVoice.git'
'git+https://github.com/RHVoice/evgeniy-rus.git'
'git+https://github.com/RHVoice/evgeniy-eng.git'
'git+https://github.com/rhvoice/aleksandr-hq-rus.git'
- 'git+https://github.com/rhvoice/yuriy-rus.git')
+ 'git+https://github.com/rhvoice/yuriy-rus.git'
+ 'git+https://github.com/rhvoice/volodymyr-ukr.git')
md5sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'SKIP')
pkgver() {
- cd "$srcdir/${pkgname%-git}"
+ cd "${pkgname%-git}"
printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
}
prepare() {
- cd "$srcdir/${pkgname%-git}"
+ cd "${pkgname%-git}"
git submodule init
git config submodule.data/voices/victoria.url "$srcdir/victoria-ru"
git config submodule.data/voices/evgeniy-rus.url "$srcdir/evgeniy-rus"
git config submodule.data/voices/evgeniy-eng.url "$srcdir/evgeniy-eng"
git config submodule.data/voices/aleksandr-hq.url "$srcdir/aleksandr-hq-rus"
git config submodule.data/voices/yuriy.url "$srcdir/yuriy-rus"
+ git config submodule.data/voices/volodymyr.url "$srcdir/volodymyr-ukr"
git config submodule.external/libs/sonic.active false
git config submodule.src/third-party/cldr.active false
git config submodule.cmake/thirdparty/sanitizers.active false
@@ -51,14 +54,14 @@ prepare() {
}
build() {
- cd "$srcdir/${pkgname%-git}"
+ cd "${pkgname%-git}"
export SCONSFLAGS="$MAKEFLAGS"
scons prefix="/usr" sysconfdir="/etc" CPPFLAGS="$CPPFLAGS" CCFLAGS="$CFLAGS" \
LINKFLAGS="$LDFLAGS"
}
package() {
- cd "$srcdir/${pkgname%-git}"
+ cd "${pkgname%-git}"
export SCONSFLAGS="$MAKEFLAGS"
scons install DESTDIR="${pkgdir}" prefix="/usr" sysconfdir="/etc" \
CPPFLAGS="$CPPFLAGS" CCFLAGS="$CFLAGS" LINKFLAGS="$LDFLAGS"