summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorerik-pro2019-01-15 23:10:45 +0300
committererik-pro2019-01-15 23:12:41 +0300
commit8e3cc3678dd8e35bba7c62f88e65ed3dd0b702da (patch)
tree96a400c0bdc4e4c9b8a405f16a0e381c149cd3bd
parentcd9a3ab2d2cfe67c253eb7bb4e7efe602d6ceb29 (diff)
downloadaur-8e3cc3678dd8e35bba7c62f88e65ed3dd0b702da.tar.gz
rewrote pkgbuild
-rw-r--r--.SRCINFO16
-rwxr-xr-xPKGBUILD71
-rw-r--r--SConstruct.patch20
3 files changed, 33 insertions, 74 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 91c8071c4649..b910fba5d6d0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,22 @@
pkgbase = rhvoice-git
- pkgdesc = Free and open source speech synthesizer for Russian and other languages. Git version with client/server enabled.
- pkgver = 20181112
+ pkgdesc = Free and open source speech synthesizer for Russian and other languages. Git version
+ pkgver = 0.7.1.r14.92c9eec
pkgrel = 1
url = https://github.com/Olga-Yakovleva/RHVoice
- arch = i686
arch = x86_64
license = GPL3
makedepends = git
makedepends = scons
depends = libpulse
- depends = libao
- depends = portaudio
- depends = glibmm
- optdepends = alsa-utils: for using aplay
optdepends = rhvoice-dictionary-git: extended russian dictionary
+ optdepends = speech-dispatcher: for speech-dispatcher module support
+ optdepends = portaudio: for portaudio backend
+ optdepends = libao: for ao backend
provides = rhvoice
- replaces = rhvoice
+ conflicts = rhvoice
backup = etc/RHVoice/RHVoice.conf
+ source = git+https://github.com/Olga-Yakovleva/RHVoice.git
+ md5sums = SKIP
pkgname = rhvoice-git
diff --git a/PKGBUILD b/PKGBUILD
index 1ae4f3f6747c..de8c146f69a0 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,60 +1,39 @@
+# Maintainer: erik-pro <aarnaarn2@gmail.com>
+# Maintainer: vantu5z <vantu5z@mail.ru>
+# Contributor: der_fenix <derfenix@gmail.com>
+
pkgname=rhvoice-git
-pkgver=20181112
+pkgver=0.7.1.r14.92c9eec
pkgrel=1
-pkgdesc="Free and open source speech synthesizer for Russian and other languages. Git version with client/server enabled."
-arch=('i686' 'x86_64')
+pkgdesc="Free and open source speech synthesizer for Russian and other languages. Git version"
+arch=('x86_64')
url="https://github.com/Olga-Yakovleva/RHVoice"
license=('GPL3')
-depends=('libpulse' 'libao' 'portaudio' 'glibmm')
+depends=('libpulse')
makedepends=('git' 'scons')
-optdepends=('alsa-utils: for using aplay'
- 'rhvoice-dictionary-git: extended russian dictionary')
+optdepends=('rhvoice-dictionary-git: extended russian dictionary'
+ 'speech-dispatcher: for speech-dispatcher module support'
+ 'portaudio: for portaudio backend'
+ 'libao: for ao backend')
provides=('rhvoice')
-replaces=('rhvoice')
+conflicts=('rhvoice')
backup=('etc/RHVoice/RHVoice.conf')
+source=('git+https://github.com/Olga-Yakovleva/RHVoice.git')
+md5sums=('SKIP')
-_gitroot='https://github.com/Olga-Yakovleva/RHVoice.git'
-_gitname='RHVoice'
+pkgver() {
+ cd "$srcdir/RHVoice"
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
build() {
- cd "$srcdir"
- msg "Connecting to GIT server...."
-
- if [[ -d "$_gitname" ]]; then
- cd "$_gitname" && git checkout SConstruct && git pull origin
- msg "The local files are updated."
- else
- git clone --depth 1 "$_gitroot" "$_gitname"
- fi
-
- msg "GIT checkout done or server timeout"
-
- msg2 "Patching source, enable client/server capabilytis"
- cd "${srcdir}"
- for p in ../*.patch; do
- msg2 "Applying patch: $p"
- patch -p1 -i "$p" --binary
- done
-
- msg "Starting build..."
- cd "$srcdir/$_gitname"
-
- scons prefix="/usr" sysconfdir="/etc" || return 1
+ cd "$srcdir/RHVoice"
+ scons prefix="/usr" sysconfdir="/etc"
}
package() {
- echo "Installing package"
- cd "$srcdir/$_gitname"
- mkdir -p ${pkgdir}{/usr/bin/,/etc/RHVoice,/usr/lib/,/usr/include,/usr/share/RHVoice,/usr/lib/speech-dispatcher-modules}
- install -D build/linux/service/RHVoice{-service,-client} "${pkgdir}/usr/bin/"
- install -D build/linux/test/RHVoice-test "${pkgdir}/usr/bin/"
- install -D build/linux/sd_module/sd_rhvoice "${pkgdir}/usr/lib/speech-dispatcher-modules/"
- install -D -m 644 config/RHVoice.conf "${pkgdir}/etc/RHVoice/"
- cp -R config/dicts/ "$pkgdir/etc/RHVoice/"
- install -m 644 build/linux/lib/libRHVoice.so "${pkgdir}/usr/lib"
- install -m 644 build/linux/core/libRHVoice_core.so "${pkgdir}/usr/lib"
- install -m 644 build/linux/audio/libRHVoice_audio.so "${pkgdir}/usr/lib"
- install -m 644 src/include/RHVoice.h "${pkgdir}/usr/include/"
- cp -R data/* "${pkgdir}/usr/share/RHVoice"
- rm "${pkgdir}/usr/share/RHVoice/SConscript"
+ cd "$srcdir/RHVoice"
+ mkdir -p "${pkgdir}/usr/lib/speech-dispatcher-modules"
+ scons install DESTDIR="${pkgdir}" prefix="/usr" sysconfdir="/etc"
+ ln -s "/usr/bin/sd_rhvoice" "${pkgdir}/usr/lib/speech-dispatcher-modules/sd_rhvoice"
}
diff --git a/SConstruct.patch b/SConstruct.patch
deleted file mode 100644
index 6b69e46253dd..000000000000
--- a/SConstruct.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- SConstruct.orig
-+++ /RHVoice/SConstruct
-@@ -178,7 +178,7 @@
- env.Tool("xp_compat")
- if "gcc" in env["TOOLS"]:
- env.MergeFlags("-pthread")
-- env.AppendUnique(CXXFLAGS=["-std=c++03"])
-+ env.AppendUnique(CXXFLAGS=["-std=c++11"])
- env.AppendUnique(CFLAGS=["-std=c99"])
- if sys.platform=="win32":
- bits="64" if arch.endswith("64") else "32"
-@@ -234,7 +234,7 @@
- env["audio_libs"].add("portaudio")
- if env["audio_libs"]:
- CheckLibspeechdVersionH(conf)
--# has_giomm=conf.CheckPKG("giomm-2.4")
-+ has_giomm=conf.CheckPKG("giomm-2.4")
- if env["PLATFORM"]=="win32":
- env.AppendUnique(LIBS="kernel32")
- conf.Finish()