summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHugo Osvaldo Barrera2015-06-09 02:59:32 -0300
committerHugo Osvaldo Barrera2015-06-09 03:00:46 -0300
commitc54e35be6197059ac41536ab93863227ddd1705e (patch)
treef11b9db1bdd1f40dbb8649fc1f6865264705ec97
downloadaur-c54e35be6197059ac41536ab93863227ddd1705e.tar.gz
Initial commit.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD32
-rw-r--r--rhythmbox-llyrics.install18
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5cc20fdeb0a9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = rhythmbox-llyrics
+ pkgdesc = A Rhythmbox plugin for displaying lyrics in the sidebar.
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/dmo60/lLyrics
+ install = rhythmbox-llyrics.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = rhythmbox>=3.0
+ depends = python-chardet
+ depends = python-lxml
+ source = https://github.com/dmo60/lLyrics/archive/v1.0.zip
+ md5sums = d6b9a5dd1282d69bcd5e8f974c05cfa6
+
+pkgname = rhythmbox-llyrics
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..01dea420b6a8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Hugo Osvaldo Barrera <hugo@barrera.io>
+
+pkgname=rhythmbox-llyrics
+pkgver=1.0
+pkgrel=1
+pkgdesc="A Rhythmbox plugin for displaying lyrics in the sidebar."
+url="https://github.com/dmo60/lLyrics"
+arch=('i686' 'x86_64')
+license=('GPL')
+makedepends=('git')
+depends=('rhythmbox>=3.0' 'python-chardet' 'python-lxml' )
+install=$pkgname.install
+source=("https://github.com/dmo60/lLyrics/archive/v$pkgver.zip")
+md5sums=('d6b9a5dd1282d69bcd5e8f974c05cfa6')
+
+_plugin_name=llyrics
+
+package() {
+ cd "$srcdir/lLyrics-$pkgver"
+
+ install -Dm 644 README.md "$pkgdir/usr/share/doc/$pkgname/README.md"
+
+ mkdir -p "$pkgdir/usr/share/glib-2.0/schemas/"
+ cp -R *.gschema.xml "$pkgdir/usr/share/glib-2.0/schemas/"
+
+ cd "${srcdir}/lLyrics-$pkgver/lLyrics"
+ mkdir -p "$pkgdir/usr/lib/rhythmbox/plugins/$_plugin_name"
+ cp -R {*.py,*.plugin,*.png,../README.md} "$pkgdir/usr/lib/rhythmbox/plugins/$_plugin_name/"
+
+ mkdir -p "$pkgdir/usr/share/rhythmbox/plugins/$_plugin_name/"
+ cp -R locale "$pkgdir/usr/share/rhythmbox/plugins/$_plugin_name/"
+}
diff --git a/rhythmbox-llyrics.install b/rhythmbox-llyrics.install
new file mode 100644
index 000000000000..5e0141942224
--- /dev/null
+++ b/rhythmbox-llyrics.install
@@ -0,0 +1,18 @@
+compile_glib2_schemas() {
+ /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas/
+}
+
+post_install() {
+ echo 'compiling glib2 schemas'
+ compile_glib2_schemas
+}
+
+post_upgrade() {
+ echo 'recompiling glib2 schemas'
+ compile_glib2_schemas
+}
+
+post_remove() {
+ echo 'recompiling glib2 schemas'
+ compile_glib2_schemas
+}