summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormirandir2015-06-24 19:48:55 +0200
committermirandir2015-06-24 19:48:55 +0200
commit6df7064826a2b59759c93d1af66eec8c66863ac0 (patch)
tree6f5947c18ba38c3b61e3b5440175b382040157cc
parent9ee87a45b318b579b99efd759685aa5235e92366 (diff)
downloadaur-6df7064826a2b59759c93d1af66eec8c66863ac0.tar.gz
Adopted and updated to install translations
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD13
2 files changed, 12 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 64b1980527fe..cffd84579a09 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = rhythmbox-plugin-alternative-toolbar-git
pkgdesc = Replace the Rhythmbox large toolbar with a Client-Side Decorated or Compact Toolbar which can be hidden
- pkgver = 0.r75.1f2c699
- pkgrel = 1
+ pkgver = 0.r210.fc71d3c
+ pkgrel = 2
url = https://github.com/fossfreedom/alternative-toolbar
install = rhythmbox-plugin-alternative-toolbar.install
arch = any
license = GPL3
makedepends = git
+ makedepends = gettext
depends = python-gobject
depends = python-lxml
depends = rhythmbox
diff --git a/PKGBUILD b/PKGBUILD
index 41cfcd5c749d..075d33a7970d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,15 @@
-# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+# Maintainer: mirandir <mirandir@orange.fr>
+# Old maintainer: Maxime Gauduin <alucryd@archlinux.org>
pkgname=rhythmbox-plugin-alternative-toolbar-git
-pkgver=0.r75.1f2c699
-pkgrel=1
+pkgver=0.r210.fc71d3c
+pkgrel=2
pkgdesc='Replace the Rhythmbox large toolbar with a Client-Side Decorated or Compact Toolbar which can be hidden'
url='https://github.com/fossfreedom/alternative-toolbar'
arch=('any')
license=('GPL3')
depends=('python-gobject' 'python-lxml' 'rhythmbox')
-makedepends=('git')
+makedepends=('git' 'gettext')
provides=('rhythmbox-plugin-alternative-toolbar')
conflicts=('rhythmbox-plugin-alternative-toolbar')
install='rhythmbox-plugin-alternative-toolbar.install'
@@ -25,12 +26,16 @@ package() {
cd rhythmbox-plugin-alternative-toolbar
install -dm 755 "${pkgdir}"/usr/{lib,share}/rhythmbox/plugins/alternative-toolbar
+ install -dm 755 "${pkgdir}"/usr/share/locale
cp -dr --no-preserve='ownership' alternative-toolbar.plugin *.py "${pkgdir}"/usr/lib/rhythmbox/plugins/alternative-toolbar/
python -m compileall "${pkgdir}"/usr/lib/rhythmbox/plugins/alternative-toolbar
python -O -m compileall "${pkgdir}"/usr/lib/rhythmbox/plugins/alternative-toolbar
cp -dr --no-preserve='ownership' img ui "${pkgdir}"/usr/share/rhythmbox/plugins/alternative-toolbar/
install -dm 755 "${pkgdir}"/usr/share/glib-2.0/schemas
install -m 644 schema/org.gnome.rhythmbox.plugins.alternative_toolbar.gschema.xml "${pkgdir}"/usr/share/glib-2.0/schemas/
+
+ cd po
+ ./install_all.sh "${pkgdir}"/usr/share/locale/
}
# vim: ts=2 sw=2 et: