summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2015-06-08 11:11:25 +0200
committerMaxime Gauduin2015-06-08 11:11:25 +0200
commit9ee87a45b318b579b99efd759685aa5235e92366 (patch)
tree914d2704a0a298c4bb658f7f8c6307783493dfb0
downloadaur-9ee87a45b318b579b99efd759685aa5235e92366.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD36
-rw-r--r--rhythmbox-plugin-alternative-toolbar.install15
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..64b1980527fe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = rhythmbox-plugin-alternative-toolbar-git
+ pkgdesc = Replace the Rhythmbox large toolbar with a Client-Side Decorated or Compact Toolbar which can be hidden
+ pkgver = 0.r75.1f2c699
+ pkgrel = 1
+ url = https://github.com/fossfreedom/alternative-toolbar
+ install = rhythmbox-plugin-alternative-toolbar.install
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = python-gobject
+ depends = python-lxml
+ depends = rhythmbox
+ provides = rhythmbox-plugin-alternative-toolbar
+ conflicts = rhythmbox-plugin-alternative-toolbar
+ source = rhythmbox-plugin-alternative-toolbar::git+https://github.com/fossfreedom/alternative-toolbar.git
+ sha256sums = SKIP
+
+pkgname = rhythmbox-plugin-alternative-toolbar-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..41cfcd5c749d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+
+pkgname=rhythmbox-plugin-alternative-toolbar-git
+pkgver=0.r75.1f2c699
+pkgrel=1
+pkgdesc='Replace the Rhythmbox large toolbar with a Client-Side Decorated or Compact Toolbar which can be hidden'
+url='https://github.com/fossfreedom/alternative-toolbar'
+arch=('any')
+license=('GPL3')
+depends=('python-gobject' 'python-lxml' 'rhythmbox')
+makedepends=('git')
+provides=('rhythmbox-plugin-alternative-toolbar')
+conflicts=('rhythmbox-plugin-alternative-toolbar')
+install='rhythmbox-plugin-alternative-toolbar.install'
+source=('rhythmbox-plugin-alternative-toolbar::git+https://github.com/fossfreedom/alternative-toolbar.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd rhythmbox-plugin-alternative-toolbar
+
+ echo "0.r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd rhythmbox-plugin-alternative-toolbar
+
+ install -dm 755 "${pkgdir}"/usr/{lib,share}/rhythmbox/plugins/alternative-toolbar
+ cp -dr --no-preserve='ownership' alternative-toolbar.plugin *.py "${pkgdir}"/usr/lib/rhythmbox/plugins/alternative-toolbar/
+ python -m compileall "${pkgdir}"/usr/lib/rhythmbox/plugins/alternative-toolbar
+ python -O -m compileall "${pkgdir}"/usr/lib/rhythmbox/plugins/alternative-toolbar
+ cp -dr --no-preserve='ownership' img ui "${pkgdir}"/usr/share/rhythmbox/plugins/alternative-toolbar/
+ install -dm 755 "${pkgdir}"/usr/share/glib-2.0/schemas
+ install -m 644 schema/org.gnome.rhythmbox.plugins.alternative_toolbar.gschema.xml "${pkgdir}"/usr/share/glib-2.0/schemas/
+}
+
+# vim: ts=2 sw=2 et:
diff --git a/rhythmbox-plugin-alternative-toolbar.install b/rhythmbox-plugin-alternative-toolbar.install
new file mode 100644
index 000000000000..f4d9c4b0811b
--- /dev/null
+++ b/rhythmbox-plugin-alternative-toolbar.install
@@ -0,0 +1,15 @@
+post_install() {
+ glib-compile-schemas /usr/share/glib-2.0/schemas
+}
+
+post_upgrade()
+{
+ post_install
+}
+
+post_remove()
+{
+ post_install
+}
+
+# vim: ts=2 sw=2 et: