summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormirandir2016-08-22 09:25:37 +0200
committermirandir2016-08-22 09:25:37 +0200
commitfba38464488ad153628950877d8c5d948b02faec (patch)
treeeb02ec7ebd8e7c66b70f9958a2aff5c9aced877e
parent0e1c0fd151ab0eeb65f9d14bc9ff3ff8c521e944 (diff)
downloadaur-fba38464488ad153628950877d8c5d948b02faec.tar.gz
Added a temporary patch for Rhythmbox 3.4.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
-rw-r--r--rb.patch14
3 files changed, 24 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 45989ecc670e..f34755874685 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = rhythmbox-plugin-alternative-toolbar-git
pkgdesc = Replace the Rhythmbox large toolbar with a Client-Side Decorated or Compact Toolbar which can be hidden
- pkgver = 0.r267.f2440cd
- pkgrel = 1
+ pkgver = 0.r291.c5b9af4
+ pkgrel = 2
url = https://github.com/fossfreedom/alternative-toolbar
install = rhythmbox-plugin-alternative-toolbar.install
arch = any
@@ -15,7 +15,9 @@ pkgbase = rhythmbox-plugin-alternative-toolbar-git
provides = rhythmbox-plugin-alternative-toolbar
conflicts = rhythmbox-plugin-alternative-toolbar
source = rhythmbox-plugin-alternative-toolbar::git+https://github.com/fossfreedom/alternative-toolbar.git
+ source = rb.patch
sha256sums = SKIP
+ sha256sums = 0e41843a342ec21e3838013856dd21ffcf178bdc05441dbc84da2e476e7aab3b
pkgname = rhythmbox-plugin-alternative-toolbar-git
diff --git a/PKGBUILD b/PKGBUILD
index 1c30d7172b38..036b174318be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Old maintainer: Maxime Gauduin <alucryd@archlinux.org>
pkgname=rhythmbox-plugin-alternative-toolbar-git
-pkgver=0.r267.f2440cd
-pkgrel=1
+pkgver=0.r291.c5b9af4
+pkgrel=2
pkgdesc='Replace the Rhythmbox large toolbar with a Client-Side Decorated or Compact Toolbar which can be hidden'
url='https://github.com/fossfreedom/alternative-toolbar'
arch=('any')
@@ -13,8 +13,9 @@ makedepends=('git' 'gettext' 'intltool')
provides=('rhythmbox-plugin-alternative-toolbar')
conflicts=('rhythmbox-plugin-alternative-toolbar')
install='rhythmbox-plugin-alternative-toolbar.install'
-source=('rhythmbox-plugin-alternative-toolbar::git+https://github.com/fossfreedom/alternative-toolbar.git')
-sha256sums=('SKIP')
+source=('rhythmbox-plugin-alternative-toolbar::git+https://github.com/fossfreedom/alternative-toolbar.git' 'rb.patch')
+sha256sums=('SKIP'
+ '0e41843a342ec21e3838013856dd21ffcf178bdc05441dbc84da2e476e7aab3b')
pkgver() {
cd rhythmbox-plugin-alternative-toolbar
@@ -24,6 +25,7 @@ pkgver() {
package() {
cd rhythmbox-plugin-alternative-toolbar
+ patch -lp0 < ../rb.patch
./autogen.sh --prefix=${pkgdir}/usr
make
make install
diff --git a/rb.patch b/rb.patch
new file mode 100644
index 000000000000..cd14ed1e84fa
--- /dev/null
+++ b/rb.patch
@@ -0,0 +1,14 @@
+--- alttoolbar_rb3compat.py.orig 2016-08-22 09:16:26.609766000 +0200
++++ alttoolbar_rb3compat.py 2016-08-22 09:18:17.856062014 +0200
+@@ -540,9 +540,9 @@
+ self.shell.props.window.add_action(action)
+ self.actiongroup.add_action(action)
+
+- if accel:
++ '''if accel:
+ app.add_accelerator(accel, action_type + "." + action_name,
+- None)
++ None)'''
+ else:
+ if 'stock_id' in args:
+ stock_id = args['stock_id']