summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnthony Vitacco2015-08-13 12:51:01 -0400
committerAnthony Vitacco2015-08-13 12:51:01 -0400
commit0a72d84fa8c0900e9eb97a2be0027fce2af38262 (patch)
treee11c8ced4acb7bb1521a1697a6f1e1f373497377
downloadaur-0a72d84fa8c0900e9eb97a2be0027fce2af38262.tar.gz
Initial Check-in
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD36
-rw-r--r--rhythmbox-plugin-ampache-git.install11
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f72fc8a1794c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = rhythmbox-plugin-ampache-git
+ pkgdesc = Rhythmbox plugin to stream music from Ampache
+ pkgver = 7415a69
+ pkgrel = 1
+ url = https://github.com/lotan/rhythmbox-ampache
+ install = rhythmbox-plugin-ampache-git.install
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = rhythmbox>=3.0
+ depends = python
+ provides = rhythmbox-plugin-ampache
+ source = rhythmbox-plugin-ampache-git::git+https://github.com/lotan/rhythmbox-ampache
+ sha1sums = SKIP
+
+pkgname = rhythmbox-plugin-ampache-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..833eabd33a62
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Anthony Vitacco <anthony@littlegno.me>
+pkgname=rhythmbox-plugin-ampache-git
+pkgver=7415a69
+pkgrel=1
+pkgdesc=" Rhythmbox plugin to stream music from Ampache"
+arch=('any')
+url="https://github.com/lotan/rhythmbox-ampache"
+license=('GPL')
+depends=('rhythmbox>=3.0' 'python')
+makedepends=('git')
+provides=('rhythmbox-plugin-ampache')
+install="rhythmbox-plugin-ampache-git.install"
+source=(${pkgname}::git+https://github.com/lotan/rhythmbox-ampache)
+sha1sums=('SKIP')
+replace=rhythmbox-ampache-svn
+
+pkgver() {
+ cd "${pkgname}"
+ git describe --always | sed 's|-|.|g'
+}
+
+package() {
+ mkdir -p $pkgdir/usr/share/rhythmbox/plugins/ampache
+ mkdir -p $pkgdir/usr/share/glib-2.0/schemas/
+ mkdir -p $pkgdir/usr/lib/rhythmbox/plugins/ampache/
+
+ cd "$srcdir/$pkgname"
+
+ install -Dm644 *.py $pkgdir/usr/lib/rhythmbox/plugins/ampache/
+ install -Dm644 ampache.plugin $pkgdir/usr/lib/rhythmbox/plugins/ampache/
+ install -Dm644 ampache-prefs.ui $pkgdir/usr/share/rhythmbox/plugins/ampache
+ install -Dm644 ampache.ico $pkgdir/usr/share/rhythmbox/plugins/ampache
+ install -Dm644 ampache.png $pkgdir/usr/share/rhythmbox/plugins/ampache
+ install -Dm644 org.gnome.rhythmbox.plugins.ampache.gschema.xml $pkgdir/usr/share/glib-2.0/schemas
+}
+
diff --git a/rhythmbox-plugin-ampache-git.install b/rhythmbox-plugin-ampache-git.install
new file mode 100644
index 000000000000..3a06d45b9a40
--- /dev/null
+++ b/rhythmbox-plugin-ampache-git.install
@@ -0,0 +1,11 @@
+post_install() {
+ glib-compile-schemas /usr/share/glib-2.0/schemas/
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}