summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHexcles Ma2015-11-14 00:25:58 -0800
committerHexcles Ma2015-11-14 00:25:58 -0800
commit83005e0c51857834837eed45a48686a3e7af2e79 (patch)
treeb9b46acc05321fd2c2c1100afaca7bed6c659b5d
downloadaur-83005e0c51857834837eed45a48686a3e7af2e79.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD44
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..29087b8c8067
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = rhythmbox-plugin-fileorganizer-git
+ pkgdesc = Music library organizer (move and rename files according to Rhythmbox database)
+ pkgver = 3.r16.ce123eb
+ pkgrel = 1
+ url = https://github.com/lachlan-00/rb-fileorganizer
+ arch = any
+ license = CCPL
+ makedepends = git
+ depends = rhythmbox
+ depends = python-gobject
+ provides = rhythmbox-plugin-fileorganizer
+ conflicts = rhythmbox-plugin-fileorganizer
+ source = git+https://github.com/lachlan-00/rb-fileorganizer.git
+ sha256sums = SKIP
+
+pkgname = rhythmbox-plugin-fileorganizer-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9783b52b157a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Hexcles Ma <bob1211@gmail.com>
+pkgname=rhythmbox-plugin-fileorganizer-git
+pkgver=3.r16.ce123eb
+pkgrel=1
+pkgdesc="Music library organizer (move and rename files according to Rhythmbox database)"
+arch=('any')
+url="https://github.com/lachlan-00/rb-fileorganizer"
+license=('CCPL')
+groups=()
+depends=('rhythmbox' 'python-gobject')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+replaces=()
+backup=()
+options=()
+install=
+source=('git+https://github.com/lachlan-00/rb-fileorganizer.git')
+noextract=()
+sha256sums=('SKIP')
+
+_gitroot='rb-fileorganizer'
+
+pkgver() {
+ cd "$srcdir/${_gitroot}"
+# No tags available, but the author mentioned in README this was "version 3".
+ printf "3.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+
+package() {
+ cd "$srcdir/${_gitroot}"
+# make INSTALLPATH="$pkgdir/usr/lib/rhythmbox/plugins/fileorganizer/" install-req
+ install -dm 755 "${pkgdir}"/usr/{lib,share}/rhythmbox/plugins/fileorganizer/
+ install -m 644 *.py "${pkgdir}/usr/lib/rhythmbox/plugins/fileorganizer/"
+ python -O -m compileall "${pkgdir}/usr/lib/rhythmbox/plugins/fileorganizer/"
+ install -m 644 fileorganizer.plugin "${pkgdir}/usr/lib/rhythmbox/plugins/fileorganizer/"
+
+ install -m 644 *.ui "${pkgdir}/usr/share/rhythmbox/plugins/fileorganizer/"
+ cp -r template "${pkgdir}/usr/share/rhythmbox/plugins/fileorganizer/"
+
+ install -dm 755 "${pkgdir}/usr/share/licenses/${pkgname}/"
+ install -m 644 LICENSE AUTHORS "${pkgdir}/usr/share/licenses/${pkgname}/"
+}