summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjohnnybash2017-11-19 14:17:10 +0100
committerjohnnybash2017-11-19 14:17:10 +0100
commit814c9c5c15e4237df5ae48af42581843ba47b48b (patch)
tree121d142177aa9ab26a474a2ca81070ad69475c79
downloadaur-814c9c5c15e4237df5ae48af42581843ba47b48b.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b14cee8874f2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Sun Nov 19 13:15:45 UTC 2017
+pkgbase = rhythmbox-plugin-hide-git
+ pkgdesc = enabled rhythmbox to start either hidden or minimized
+ pkgver = 14.8f48bb1
+ pkgrel = 1
+ url = https://github.com/fossfreedom/rhythmbox_hide
+ arch = any
+ license = GPL3
+ depends = rhythmbox
+ provides = rhythmbox-hide
+ source = git+https://github.com/fossfreedom/rhythmbox_hide.git
+ md5sums = SKIP
+
+pkgname = rhythmbox-plugin-hide-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0c3991213455
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: johnnybash <georgpfahler at wachenzell dot org>
+
+pkgname=rhythmbox-plugin-hide-git
+_pkgname=rhythmbox_hide
+pkgver=14.8f48bb1
+pkgrel=1
+pkgdesc="enabled rhythmbox to start either hidden or minimized"
+arch=("any")
+url="https://github.com/fossfreedom/rhythmbox_hide"
+license=("GPL3")
+provides=("rhythmbox-hide")
+depends=("rhythmbox")
+source=("git+https://github.com/fossfreedom/rhythmbox_hide.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ install -Dm644 rhythmbox_hide.plugin "${pkgdir}/usr/lib/rhythmbox/plugins/${_pkgname}/rhythmbox_hide.plugin"
+ install -Dm644 rhythmbox_hide.py "${pkgdir}/usr/lib/rhythmbox/plugins/${_pkgname}/rhythmbox_hide.py"
+ install -Dm644 schema/org.gnome.rhythmbox.plugins.rhythmbox_hide.gschema.xml "${pkgdir}/usr/share/glib-2.0/schemas/org.gnome.rhythmbox.plugins.rhythmbox_hide.gschema.xml"
+}