summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephen Martin2015-06-12 13:16:11 -0500
committerStephen Martin2015-06-12 13:16:11 -0500
commit167cba596561b5a029597f7217540c30b74d285d (patch)
tree9a5620b4baf88fb4c359b4e2cc5c1fae885e1909
downloadaur-167cba596561b5a029597f7217540c30b74d285d.tar.gz
Converted to aur4
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..00287468c55b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = rhythmbox-plugin-radio-browser-git
+ pkgdesc = Rhythmbox plugin that shows the radio station lists of icecast and shoutcast directly in rhythmbox
+ pkgver = 3.0
+ pkgrel = 2
+ url = http://www.radio-browser.info
+ arch = any
+ license = GPL3
+ depends = rhythmbox
+ depends = streamripper
+ source = rhythmbox-plugin-radio-browser-git::git+https://github.com/fossfreedom/radio-browser.git#branch=rb3
+ md5sums = SKIP
+
+pkgname = rhythmbox-plugin-radio-browser-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ff614c0a902a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Stephen Martin <hwkiller at gmail dot com>
+pkgname=rhythmbox-plugin-radio-browser-git
+pkgver=3.0
+pkgrel=2
+pkgdesc="Rhythmbox plugin that shows the radio station lists of icecast and shoutcast directly in rhythmbox"
+arch=(any)
+url="http://www.radio-browser.info"
+license=('GPL3')
+depends=('rhythmbox' 'streamripper')
+source=("$pkgname::git+https://github.com/fossfreedom/radio-browser.git#branch=rb3")
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+package() {
+ cd $srcdir/$pkgname
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums=('SKIP')