summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlastavengers2016-05-17 09:27:21 +0800
committerlastavengers2016-05-17 09:27:21 +0800
commitd844eaaa0ee463541a04c0109738a5c4cbab4209 (patch)
tree725fa5e270b9fc8d051c023ac0d49eea9be6f987
parent245366fb06b3a7b93dbc59899c19d2f4e154e680 (diff)
downloadaur-d844eaaa0ee463541a04c0109738a5c4cbab4209.tar.gz
bump version to 0.0.9
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD21
2 files changed, 17 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4be086d04864..899204f236c7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
# Generated by mksrcinfo v8
-# Fri May 6 15:49:03 UTC 2016
+# Tue May 17 01:26:56 UTC 2016
pkgbase = ricin
pkgdesc = A dead-simple but powerful Tox client.
- pkgver = 0.0.7
- pkgrel = 2
- url = https://github.com/RicinApp/Ricin
+ pkgver = 0.0.9
+ pkgrel = 1
+ url = https://ricin.im/
arch = i686
arch = x86_64
license = GPL3
makedepends = git
- makedepends = meson
- makedepends = ninja
makedepends = vala
+ makedepends = python
depends = gtk3
depends = toxcore
depends = glib2
@@ -20,8 +19,8 @@ pkgbase = ricin
depends = libnotify
provides = ricin
conflicts = ricin
- source = https://github.com/RicinApp/Ricin/archive/v0.0.7.tar.gz
- sha256sums = 861a403fec1206323c34c71dff92c29bdffea97e21617e8b02bdb0bc00301698
+ source = https://github.com/RicinApp/Ricin/archive/v0.0.9.tar.gz
+ sha256sums = 54389639b1f21690eb3650f1e6635363f5dbcf02ed4c9f28b7efc88c3b1522f4
pkgname = ricin
diff --git a/PKGBUILD b/PKGBUILD
index bcce9da41edf..9303221191e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
pkgname=ricin
_pkgname=Ricin
-pkgver=0.0.7
-pkgrel=2
+pkgver=0.0.9
+pkgrel=1
pkgdesc="A dead-simple but powerful Tox client."
-url="https://github.com/RicinApp/Ricin"
+url="https://ricin.im/"
arch=('i686' 'x86_64')
license=('GPL3')
-makedepends=('git' 'meson' 'ninja' 'vala')
+makedepends=('git' 'vala' 'python')
depends=('gtk3'
'toxcore'
'glib2'
@@ -18,24 +18,23 @@ depends=('gtk3'
)
source=("https://github.com/RicinApp/${_pkgname}/archive/v${pkgver}.tar.gz")
-sha256sums=('861a403fec1206323c34c71dff92c29bdffea97e21617e8b02bdb0bc00301698')
+sha256sums=('54389639b1f21690eb3650f1e6635363f5dbcf02ed4c9f28b7efc88c3b1522f4')
provides=('ricin')
conflicts=('ricin')
build() {
cd "${srcdir}/${_pkgname}-${pkgver}"
- make autogen
- make release
-
- cd build
- mesonconf.py -Dprefix=/usr
+ ./waf distclean
+ ./waf configure --prefix=${pkgdir}/usr --bindir=${pkgdir}/usr/bin
+ ./waf build
}
package() {
cd "${srcdir}/${_pkgname}-${pkgver}"
+ ./waf install
- make DESTDIR=$pkgdir install
# cover ${pkgdir}/usr/bin/Ricin"
+ rm "${pkgdir}/usr/bin/${_pkgname}"
install -Dm755 "build/${_pkgname}" "${pkgdir}/usr/bin/ricin"
}