summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlastavengers2016-03-21 14:35:47 +0800
committerlastavengers2016-03-21 14:35:47 +0800
commit72ab60ad66b38334fb64a39c763a23da2c3351c3 (patch)
treee25afbfa2050fd2b81f962a2e00eb2cd185d8d4d
parentd577c930922f700c6471a9e75a5c747d9af6ca5d (diff)
downloadaur-72ab60ad66b38334fb64a39c763a23da2c3351c3.tar.gz
fix git
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD19
2 files changed, 18 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index afde3c4f7d9c..2522bc235edf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
# Generated by mksrcinfo v8
-# Sat Mar 19 05:32:29 UTC 2016
+# Mon Mar 21 06:35:26 UTC 2016
pkgbase = ricin-git
pkgdesc = Lightweight and Fully-Hackable Tox client powered by Vala & Gtk3
- pkgver = 0.452.b519ec3
- pkgrel = 2
+ pkgver = 0.467.11d69a5
+ pkgrel = 1
url = https://github.com/RicinApp/Ricin
arch = i686
arch = x86_64
license = GPL3
+ makedepends = git
makedepends = meson
makedepends = ninja
makedepends = vala
diff --git a/PKGBUILD b/PKGBUILD
index c7fab26a188a..326c09e28a2b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,22 @@
pkgname=ricin-git
_pkgname=Ricin
_submodule=tox-vapi
-pkgver=0.452.b519ec3
-pkgrel=2
+pkgver=0.467.11d69a5
+pkgrel=1
pkgdesc="Lightweight and Fully-Hackable Tox client powered by Vala & Gtk3"
url="https://github.com/RicinApp/Ricin"
arch=('i686' 'x86_64')
license=('GPL3')
-makedepends=('meson' 'ninja' 'vala')
-depends=('gtk3' 'toxcore' 'glib2' 'json-glib' 'libsoup' 'libnotify' 'libconfig')
+makedepends=('git' 'meson' 'ninja' 'vala')
+depends=('gtk3'
+ 'toxcore'
+ 'glib2'
+ 'json-glib'
+ 'libsoup'
+ 'libnotify'
+ 'libconfig'
+ )
+
source=("git+https://github.com/RicinApp/Ricin.git"
"git+https://github.com/RicinApp/tox-vapi.git")
sha256sums=('SKIP' 'SKIP')
@@ -43,6 +51,7 @@ build() {
package() {
cd "${srcdir}/${_pkgname}"
- install -Dm644 "misc/ricin.desktop" "${pkgdir}/usr/share/applications/ricin.desktop"
+ install -Dm644 "icons/Ricin-128x128.png" "${pkgdir}/usr/share/icons/icons/Ricin-128x128.png"
+ install -Dm644 "ricin.desktop" "${pkgdir}/usr/share/applications/ricin.desktop"
install -Dm755 "build/${_pkgname}" "${pkgdir}/usr/bin/ricin"
}