summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlastavengers2016-01-21 14:44:02 +0800
committerlastavengers2016-01-21 14:44:02 +0800
commitf85cbc2d0686172ebe115f0e48ab98e9b39b3fa5 (patch)
treeb18ae088990e6b752b19842c9f778df23ff0d855
downloadaur-f85cbc2d0686172ebe115f0e48ab98e9b39b3fa5.tar.gz
Initial import
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD43
2 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ac4336c1fe25
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+# Generated by mksrcinfo v8
+# Thu Jan 21 06:43:08 UTC 2016
+pkgbase = ricin-git
+ pkgdesc = Lightweight and Fully-Hackable Tox client powered by Vala & Gtk3
+ pkgver = 0.233.47be533
+ pkgrel = 1
+ url = https://github.com/RicinApp/Ricin
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = meson
+ makedepends = ninja
+ makedepends = vala
+ depends = gtk3
+ depends = toxcore
+ depends = glib2
+ depends = json-glib
+ depends = libsoup
+ depends = libnotify
+ provides = ricin
+ conflicts = ricin
+ source = git+https://github.com/RicinApp/Ricin.git
+ source = git+https://github.com/RicinApp/tox-vapi.git
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = ricin-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ddd577730d38
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Yuexuan Gu <lastavengers@outlook.com>
+
+pkgname=ricin-git
+_pkgname=Ricin
+_submodule=tox-vapi
+pkgver=0.233.47be533
+pkgrel=1
+pkgdesc="Lightweight and Fully-Hackable Tox client powered by Vala & Gtk3"
+url="https://github.com/RicinApp/Ricin"
+arch=('i686' 'x86_64')
+license=('GPL3')
+makedepends=('meson' 'ninja' 'vala')
+depends=('gtk3' 'toxcore' 'glib2' 'json-glib' 'libsoup' 'libnotify')
+source=("git+https://github.com/RicinApp/Ricin.git"
+ "git+https://github.com/RicinApp/tox-vapi.git")
+sha256sums=('SKIP' 'SKIP')
+provides=('ricin')
+conflicts=('ricin')
+
+prepare() {
+ cd "${srcdir}/${_pkgname}"
+ git submodule init
+ git config submodule.${_submodule}.url $srcdir/${_submodule}
+ git submodule update
+ echo 'compile: ./build/' >> Makefile
+ echo ' type ninja-build 2>/dev/null && ninja-build -C build || ninja -C build' >> Makefile
+}
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ echo "0.$(git rev-list --count HEAD).$(git describe --always)"
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ mkdir build
+ meson . build
+ make compile
+}
+
+package() {
+ install -Dm755 "${srcdir}/${_pkgname}/build/${_pkgname}" "${pkgdir}/usr/bin/ricin"
+}