summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMario Finelli2016-11-14 07:32:19 -0500
committerMario Finelli2016-11-14 07:32:19 -0500
commitf892ccfa095834123da750050e9d0666a0c3acf9 (patch)
tree4da1f60e4cf15370d77875eee420b82a9e54169c
parent510dff3b2d8d960805c80cfe498a19e6acd91d52 (diff)
downloadaur-f892ccfa095834123da750050e9d0666a0c3acf9.tar.gz
Bump to 1.1.4
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD15
-rw-r--r--disable-ASAN-by-default-for-release-builds.patch31
3 files changed, 10 insertions, 50 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 964de1b8e5c3..fab3d9be9161 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Tue Apr 19 01:17:26 UTC 2016
+# Mon Nov 14 12:31:13 UTC 2016
pkgbase = ricochet
pkgdesc = Anonymous peer-to-peer instant messaging.
- pkgver = 1.1.2
- pkgrel = 4
+ pkgver = 1.1.4
+ pkgrel = 1
url = https://ricochet.im/
arch = i686
arch = x86_64
@@ -17,11 +17,9 @@ pkgbase = ricochet
depends = openssl
depends = protobuf
depends = qt5-multimedia
- source = disable-ASAN-by-default-for-release-builds.patch
- source = https://ricochet.im/releases/1.1.2/ricochet-1.1.2-src.tar.bz2
- source = https://ricochet.im/releases/1.1.2/ricochet-1.1.2-src.tar.bz2.asc
- sha256sums = ed72e9b2a2d22861c00edb9effdab1e15150137a7e70767a9fbd580b28d0a99c
- sha256sums = 97c78d088892e84c95a3e3a4a982883d8e44028848a513a5d7e0231d36325cc3
+ source = https://ricochet.im/releases/1.1.4/ricochet-1.1.4-src.tar.bz2
+ source = https://ricochet.im/releases/1.1.4/ricochet-1.1.4-src.tar.bz2.asc
+ sha256sums = f5f32caa3480def1de5c93010c6bf5f5789ddcba34bf09fc0feab67696d0c374
sha256sums = SKIP
pkgname = ricochet
diff --git a/PKGBUILD b/PKGBUILD
index 42af662b4ea9..94f3df87e551 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,26 +3,19 @@
# Contributor: Mikkel Kroman <mk at maero dot dk>
pkgname=ricochet
-pkgver=1.1.2
-pkgrel=4
+pkgver=1.1.4
+pkgrel=1
pkgdesc="Anonymous peer-to-peer instant messaging."
arch=('i686' 'x86_64')
url="https://ricochet.im/"
license=('custom')
depends=('tor' 'qt5-quick1' 'qt5-quickcontrols' 'qt5-declarative' 'openssl' 'protobuf' 'qt5-multimedia')
makedepends=('qt5-tools' 'pkg-config')
-source=('disable-ASAN-by-default-for-release-builds.patch'
- https://ricochet.im/releases/$pkgver/$pkgname-$pkgver-src.tar.bz2{,.asc})
-sha256sums=('ed72e9b2a2d22861c00edb9effdab1e15150137a7e70767a9fbd580b28d0a99c'
- '97c78d088892e84c95a3e3a4a982883d8e44028848a513a5d7e0231d36325cc3'
+source=(https://ricochet.im/releases/$pkgver/$pkgname-$pkgver-src.tar.bz2{,.asc})
+sha256sums=('f5f32caa3480def1de5c93010c6bf5f5789ddcba34bf09fc0feab67696d0c374'
'SKIP')
validpgpkeys=('9032CAE4CBFA933A5A2145D5FF97C53F183C045D')
-prepare() {
- cd "$srcdir"/$pkgname-$pkgver
- patch -p1 < "${srcdir}/disable-ASAN-by-default-for-release-builds.patch"
-}
-
build() {
cd "$srcdir"/$pkgname-$pkgver
QT_SELECT=5 qmake CONFIG+=release DEFINES+=RICOCHET_NO_PORTABLE
diff --git a/disable-ASAN-by-default-for-release-builds.patch b/disable-ASAN-by-default-for-release-builds.patch
deleted file mode 100644
index ffe7ca34d282..000000000000
--- a/disable-ASAN-by-default-for-release-builds.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 3031a5607a1659cd38e876004007e1a56ace50f8 Mon Sep 17 00:00:00 2001
-From: Jacob Appelbaum <jacob@appelbaum.net>
-Date: Mon, 21 Mar 2016 13:33:07 +0000
-Subject: [PATCH] disable ASAN by default for release builds
-
----
- hardened.pri | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/hardened.pri b/hardened.pri
-index 1b6c3b0..1bd3aaf 100644
---- a/hardened.pri
-+++ b/hardened.pri
-@@ -15,12 +15,13 @@ HARDENED_STACK_PROTECTOR_FLAGS = -fstack-protector --param=ssp-buffer-size=4
-
- HARDENED_MINGW_64ASLR_FLAGS = -Wl,--dynamicbase -Wl,--high-entropy-va
-
-+
- # Run tests and apply options where possible
- CONFIG(hardened) {
- # mingw is always PIC, and complains about the flag
- !mingw:HARDEN_FLAGS = -fPIC
-
-- qtCompileTest(sanitize):HARDEN_FLAGS += $$HARDENED_SANITIZE_FLAGS
-+ CONFIG(debug,debug|release): qtCompileTest(sanitize):HARDEN_FLAGS += $$HARDENED_SANITIZE_FLAGS
- qtCompileTest(sanitize-ubsan):HARDEN_FLAGS += $$HARDENED_SANITIZE_UBSAN_FLAGS
- qtCompileTest(sanitize-ubsan-more):HARDEN_FLAGS += $$HARDENED_SANITIZE_UBSAN_MORE_FLAGS
- qtCompileTest(vtable-verify):HARDEN_FLAGS += $$HARDENED_VTABLE_VERIFY_FLAGS
---
-2.8.0
-