summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsamogot2018-12-19 14:49:04 +0200
committersamogot2018-12-19 14:49:04 +0200
commit64e64339422f9664a023a9ab6abb6c464863597d (patch)
tree6971e38e44085a32a14b929a524eec258f6664f0
downloadaur-64e64339422f9664a023a9ab6abb6c464863597d.tar.gz
Version 1.07
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD37
-rw-r--r--ricoh-sp220-som.install45
4 files changed, 105 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..58b3b253e3b7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = ricoh-sp220-som
+ pkgdesc = Smart Organizing Monitor Utility for Ricoh SP220 series
+ pkgver = 1.07
+ pkgrel = 1
+ url = http://support.ricoh.com/bb/html/dr_ut_e/re1/model/sp221s/sp221s.htm
+ install = ricoh-sp220-som.install
+ arch = i686
+ arch = x86_64
+ license = unknown
+ makedepends = binutils
+ makedepends = p7zip
+ depends = udev
+ depends = qt4>=4.6.0
+ depends = libusb0>=0.1.12
+ source = http://support.ricoh.com/bb/pub_e/dr_ut_e/0001300/0001300712/V107/r79280en.exe
+ md5sums = 7ac157b3575f178cc0ea0897a0136549
+
+pkgname = ricoh-sp220-som
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1bd6a8b4e170
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.exe
+*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1593b87d6ec1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Ivan Naydonov <samogot@gmail.com>
+pkgname=ricoh-sp220-som
+pkgver=1.07
+pkgrel=1
+
+pkgdesc="Smart Organizing Monitor Utility for Ricoh SP220 series"
+arch=('i686' 'x86_64')
+url="http://support.ricoh.com/bb/html/dr_ut_e/re1/model/sp221s/sp221s.htm"
+license=('unknown')
+group=('ricoh-sp220-all')
+
+depends=('udev' 'qt4>=4.6.0' 'libusb0>=0.1.12')
+makedepends=('binutils' 'p7zip')
+
+install='ricoh-sp220-som.install'
+if [ "${CARCH}" = 'x86_64' ]; then
+ ARCH='amd64'
+ source=(http://support.ricoh.com/bb/pub_e/dr_ut_e/0001300/0001300712/V107/r79280en.exe)
+ md5sums=('7ac157b3575f178cc0ea0897a0136549')
+elif [ "${CARCH}" = 'i686' ]; then
+ ARCH='i386'
+ source=(http://support.ricoh.com/bb/pub_e/dr_ut_e/0001300/0001300711/V107/r79279en.exe)
+ md5sums=('691d1ac9c951c3f1edeb0f3644ee16e4')
+fi
+
+prepare() {
+ ar x som-sp-200-series_${pkgver}_$ARCH.deb
+ tar -zxf data.tar.gz
+ chmod u+s opt/smart-organizing-monitor-for-sp-200series/pingtool
+}
+
+package() {
+ install -d $pkgdir/etc
+ install -d $pkgdir/opt
+ install -d $pkgdir/usr
+ cp -a etc opt usr $pkgdir
+}
diff --git a/ricoh-sp220-som.install b/ricoh-sp220-som.install
new file mode 100644
index 000000000000..781a5e311b40
--- /dev/null
+++ b/ricoh-sp220-som.install
@@ -0,0 +1,45 @@
+
+name=smart-organizing-monitor-for-sp-200series
+
+install_system_icons() {
+ # Add icons to the system icons
+ XDG_ICON_RESOURCE="`which xdg-icon-resource 2> /dev/null`"
+ if [ -x "$XDG_ICON_RESOURCE" ]; then
+ for icon in "/opt/$name/som_"*.png; do
+ size="${icon##*/som_}"
+ "$XDG_ICON_RESOURCE" $1 --size "${size%.png}" "$icon" $name
+ done
+ fi
+}
+
+post_upgrade() {
+ #update the menu
+ UPDATE_MENUS="`which update-menus 2> /dev/null`"
+ #update the menu
+ if [ -x "$UPDATE_MENUS" ]; then
+ update-menus
+ fi
+}
+
+post_install() {
+ install_system_icons install
+
+ post_upgrade
+
+ #add w+r for DevCfg.ini
+ rm -f /home/*/.sdcdevcfgnetb.ini
+ rm -f /home/*/.som200series.ini
+ rm -f /home/*/.som200seriesa.ini
+ rm -f /home/*/.som_ui.ini
+ rm -f /home/*/.som_uia.ini
+}
+
+post_remove() {
+ post_upgrade
+}
+
+pre_remove() {
+ install_system_icons uninstall
+}
+
+