summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLászló Várady2019-03-16 14:27:22 +0100
committerLászló Várady2019-03-25 08:51:20 +0100
commit53a5ae38bc0624934130513fc4ffa1f751432e5e (patch)
tree6753c56f83376170560f9faee6a25a461d671a14
parent95e3ec4ccce092bbd8999ba0a2436d503c39dfee (diff)
downloadaur-53a5ae38bc0624934130513fc4ffa1f751432e5e.tar.gz
Update to v1.10.4
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD12
2 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 18662bc2c629..ccdcf0a4161d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
pkgbase = riemann-c-client
pkgdesc = Riemann C driver library and CLI client
- pkgver = 1.8.1
+ pkgver = 1.10.4
pkgrel = 1
url = https://github.com/algernon/riemann-c-client
arch = i686
arch = x86_64
arch = armv7h
- license = BSD
+ license = LGPL3
makedepends = git
- makedepends = automake
- makedepends = autoconf
- depends = glibc
+ makedepends = autoconf
+ makedepends = automake
depends = zlib
- depends = protobuf-c
- source = git+https://github.com/algernon/riemann-c-client#tag=1.8.1
+ depends = protobuf-c
+ depends = gnutls
+ source = git+https://github.com/algernon/riemann-c-client#tag=riemann-c-client-1.10.4
sha256sums = SKIP
pkgname = riemann-c-client
diff --git a/PKGBUILD b/PKGBUILD
index 47656d184986..10e5cc7d557f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,26 @@
# Maintainer: Pierre-Yves Ritschard <pyr@spootnik.org>
+# Maintainer: László Várady <laszlo.varady93@gmail.com>
pkgname=riemann-c-client
-pkgver=1.8.1
+pkgver=1.10.4
pkgrel=1
pkgdesc='Riemann C driver library and CLI client'
url="https://github.com/algernon/riemann-c-client"
-license=('BSD')
-source=(git+https://github.com/algernon/riemann-c-client#tag=riemann-c-client-1.8.1)
+license=('LGPL3')
+source=(git+https://github.com/algernon/riemann-c-client#tag=riemann-c-client-$pkgver)
arch=(i686 x86_64 armv7h)
-depends=(glibc zlib protobuf-c)
+depends=(zlib protobuf-c gnutls)
makedepends=(git autoconf automake)
sha256sums=('SKIP')
build() {
cd riemann-c-client
autoreconf -i
- ./configure --prefix=/usr
+ ./configure --prefix=/usr --enable-tls
make
}
package() {
cd riemann-c-client
make install DESTDIR="$pkgdir"
- install -D -m644 LGPL "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}