summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrien Prost-Boucle2021-06-24 22:18:53 +0200
committerAdrien Prost-Boucle2021-06-24 22:18:53 +0200
commit711de1095460056de93cfd6f33e7450579dba6bb (patch)
tree84fa6ff0fdecc063c7aa4484ec9084f5dc93fdc5
parent2f797932fb20bd79655f018920296cc5c5b451f7 (diff)
downloadaur-711de1095460056de93cfd6f33e7450579dba6bb.tar.gz
Fix compilation for linux >= 5.12, and switch to sha256sums
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD16
-rw-r--r--patch-subdirs.patch11
-rw-r--r--riffa.install2
4 files changed, 32 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0d35e07fa2a0..e14795afa3ea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Apr 18 20:32:53 UTC 2017
+# Thu Jun 24 20:17:19 UTC 2021
pkgbase = riffa-git
pkgdesc = RIFFA: A Reusable Integration Framework For FPGA Accelerators
- pkgver = 2.2.2.git20170213
+ pkgver = 2.2.2.git20210624
pkgrel = 1
url = http://riffa.ucsd.edu/
install = riffa.install
@@ -12,10 +12,12 @@ pkgbase = riffa-git
makedepends = linux-headers
source = git://github.com/marzoul/riffa.git
source = riffa.install
+ source = patch-subdirs.patch
source = 99-riffa.rules
- md5sums = SKIP
- md5sums = SKIP
- md5sums = d37355781ef46d1f4aa21cd169964f08
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = 102cc4edf8008a193faf15dfe507d8cdb223036de6059b4c8f495b69ead246ac
+ sha256sums = 6dd2aee2ba41d68419004f7a80b87fbd6a1d8c723d5a2b3d293fe460a7364676
pkgname = riffa-git
diff --git a/PKGBUILD b/PKGBUILD
index 8f19aa1ff09a..641e38a498fc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Important: the versions of the packages linux and linux-header must match
pkgname=riffa-git
-pkgver=2.2.2.git20170213
+pkgver=2.2.2.git20210624
pkgrel=1
arch=('i686' 'x86_64')
pkgdesc='RIFFA: A Reusable Integration Framework For FPGA Accelerators'
@@ -16,13 +16,15 @@ source=(
#"git://github.com/drichmond/riffa.git"
"git://github.com/marzoul/riffa.git"
'riffa.install'
+ 'patch-subdirs.patch'
'99-riffa.rules'
)
# Note: No check for riffa.install because it is modified by the package() function.
-md5sums=(
+sha256sums=(
'SKIP'
'SKIP'
- 'd37355781ef46d1f4aa21cd169964f08'
+ '102cc4edf8008a193faf15dfe507d8cdb223036de6059b4c8f495b69ead246ac'
+ '6dd2aee2ba41d68419004f7a80b87fbd6a1d8c723d5a2b3d293fe460a7364676'
)
pkgver() {
@@ -36,6 +38,14 @@ pkgver() {
echo $_distver.git$_gitver;
}
+prepare() {
+ cd "${srcdir}/riffa"
+
+ # At least for Linux >= 5.12
+ patch -p0 -N -i ../../patch-subdirs.patch
+
+}
+
build() {
cd "${srcdir}/riffa/driver/linux"
diff --git a/patch-subdirs.patch b/patch-subdirs.patch
new file mode 100644
index 000000000000..8253f3ea3ad9
--- /dev/null
+++ b/patch-subdirs.patch
@@ -0,0 +1,11 @@
+--- driver/linux/Makefile
++++ driver/linux/Makefile
+@@ -98,7 +98,7 @@ $(NAME).ko: *.c *.h
+ sed -i 's/#define VENDOR_ID1 [^\n]*/#define VENDOR_ID1 0x$(VENDOR_ID1)/g' $(DRVR_HDR)
+ sed -i 's/#define DEBUG [^\n]*/#define DBUG 1/g' $(DRVR_HDR)
+ sed -i 's/#define DBUG [^\n]*/#define $(DBUGVAL) 1/g' $(DRVR_HDR)
+- make -C $(KDIR) SUBDIRS=`pwd` modules
++ make -C $(KDIR) M=`pwd` modules
+ rm -rf $(LIB_OBJS)
+
+ $(NAME).so.$(LIB_VER): $(LIB_OBJS)
diff --git a/riffa.install b/riffa.install
index 9989a3ccb9c8..7cc7d952e997 100644
--- a/riffa.install
+++ b/riffa.install
@@ -1,6 +1,6 @@
_depmod() {
- EXTRAMODULES=extramodules-4.10-ARCH
+ EXTRAMODULES=extramodules-5.12-ARCH
depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
}