summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin MacMartin2022-08-30 17:05:21 -0400
committerKevin MacMartin2022-08-30 17:05:21 -0400
commit7c2c397a3b45d9972b76f6dc5ad55f85fd86819e (patch)
tree8c7f12214f29c63ec0f3ca4f35dcf7574d4417b2
parentbeeabdf78040ce72ae93863ee68027a1a6792b7f (diff)
downloadaur-7c2c397a3b45d9972b76f6dc5ad55f85fd86819e.tar.gz
Remove armv6 and armv7 as they don't build, and remove the line in wails that sets the GDK_BACKEND to x11 so it can start in a wayland session without xwayland
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 157d20eff57d..aa925f804b5f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,10 @@
pkgbase = riftshare
pkgdesc = Easy, Secure, and Free file sharing for everyone
pkgver = 0.1.9
- pkgrel = 1
+ pkgrel = 2
url = https://riftshare.app
arch = i686
arch = x86_64
- arch = armv6h
- arch = armv7h
arch = aarch64
license = GPL3
makedepends = go
diff --git a/PKGBUILD b/PKGBUILD
index a7b735dcd4d7..f112f010210e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,11 +2,11 @@
pkgname=riftshare
pkgver=0.1.9
-pkgrel=1
+pkgrel=2
pkgdesc='Easy, Secure, and Free file sharing for everyone'
url='https://riftshare.app'
license=('GPL3')
-arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
+arch=('i686' 'x86_64' 'aarch64')
depends=('webkit2gtk')
makedepends=('go')
@@ -27,7 +27,15 @@ sha512sums=(
prepare() {
rm -rf pkg
cd $pkgname-$pkgver
+
+ # Use the non-flatpak settings location
patch -p1 < ../settings-config.patch
+
+ # Predownload dependencies and patch out forcing the GDK_BACKEND to be x11 so wayland will work
+ export GOPATH="$srcdir"
+ go mod vendor -modcacherw
+ sed -i '/GDK_BACKEND/d' ../pkg/mod/github.com/wailsapp/wails/v2@v2.0.0-beta.37/internal/frontend/desktop/linux/frontend.go
+ sed -i '/^\s*"os"$/d' ../pkg/mod/github.com/wailsapp/wails/v2@v2.0.0-beta.37/internal/frontend/desktop/linux/frontend.go
}
build() {