summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreveryx2023-07-29 09:36:30 +0800
committereveryx2023-07-29 09:36:30 +0800
commit8ff092b45a067fc9264a67eaf12db5bc355ab089 (patch)
tree3d3425a3598b11a8cffbfebe18f73e2982f7cf13
parent68d3e850728866702d16364f7775036ee9996b4d (diff)
downloadaur-8ff092b45a067fc9264a67eaf12db5bc355ab089.tar.gz
fix: gram install error
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD16
2 files changed, 7 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f181f2d6695c..8c3e5abba33c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = rime-ice-git
pkgdesc = Rime 配置:雾凇拼音 | 长期维护的简体词库
- pkgver = r275.e32b3fa
+ pkgver = r301.d9c024d
pkgrel = 1
url = https://github.com/iDvel/rime-ice
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index 912b2cee5a73..0556b7f69354 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ _pkgbase=rime-ice
_schemas=(rime_ice double_pinyin double_pinyin_flypy double_pinyin_mspy double_pinyin_ziguang double_pinyin_abc)
_pkgname=$_pkgbase
pkgname=$_pkgname-git
-pkgver=r275.e32b3fa
+pkgver=r301.d9c024d
pkgrel=1
pkgdesc="Rime 配置:雾凇拼音 | 长期维护的简体词库"
arch=("any")
@@ -67,8 +67,7 @@ build() {
package() {
cd "${_pkgname}" || return
-
- _install_base=$pkgdir/usr/share/rime-data
+ _install_base="$pkgdir/usr/share/rime-data"
install -Dm644 "$_suggestion" -t "$_install_base/"
install -Dm644 ./build/*.{bin,yaml} -t "$_install_base/build"
@@ -92,17 +91,14 @@ package() {
done
for _f in */*.dict.yaml; do
- grep -q "\- ${_f/.dict.yaml/}" "$_install_base/"*.dict.yaml &&
+ if grep -q "\- ${_f/.dict.yaml/}" "$_install_base/"*.dict.yaml; then
install -Dm644 "$_f" -t "$_install_base/$(dirname "$_f")"
+ fi
done
for _f in *.yaml; do
- grep -q "${_f/.yaml/:}" build/*.schema.yaml &&
- install -Dm644 "$_f" -t "$_install_base/"
- done
-
- for _f in *.gram; do
- grep -q "${_f/.gram/}" build/*.schema.yaml &&
+ if grep -q "${_f/.yaml/:}" build/*.schema.yaml; then
install -Dm644 "$_f" -t "$_install_base/"
+ fi
done
}