summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastien Duthil2015-12-14 22:14:28 -0500
committerSebastien Duthil2015-12-14 22:14:28 -0500
commit7d3564a06cabd853382d7018aecefad665f386a1 (patch)
tree06954c1ab44574b29ae95e6186c65e9f3b548e9b
downloadaur-7d3564a06cabd853382d7018aecefad665f386a1.tar.gz
Initial package 0.12.914
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore4
-rw-r--r--LICENSE13
-rw-r--r--PKGBUILD69
-rw-r--r--rimworld.desktop9
-rw-r--r--rimworld.sh5
6 files changed, 121 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..08c63148fcd0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = rimworld
+ pkgdesc = A sci-fi colony simulation game driven by an intelligent AI storyteller.
+ pkgver = 0.12.914
+ pkgrel = 1
+ url = http://rimworldgame.com/
+ arch = i686
+ arch = x86_64
+ license = custom: commercial
+ makedepends = unzip
+ depends = glu
+ depends = lib32-gtk2
+ depends = gcc-libs-multilib
+ source = rimworld.desktop
+ source = rimworld.sh
+ source = LICENSE
+ sha256sums = e83c514731904722d96218e82e257467d7af32d938493bb5908cf96c7699cae6
+ sha256sums = 2cf317e27b0d0414cc0a9dbde784edd5e8f06ab1c71715a869e4578e7febffd3
+ sha256sums = ef210c499f47f0076204227da65110e0f2fe3316b5ae03478c21941a07e513e0
+
+pkgname = rimworld
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c991d2b5c1be
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+*.tar.xz
+*.zip
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..3375d9e6eb76
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,13 @@
+================== License clarification ===================
+============================================================
+
+In purchasing RimWorld, you purchase a perpetual license to install and use the software on up to five devices you own.
+
+You may not share game files or download links thereof. You may not install the software on someone else's machine.
+
+By modding the game you agree to these restrictions:
+ -You're welcome to make whatever mod you like and distribute it as broadly as possible.
+ -You may only distribute RimWorld mods non-commercially (for free) without discriminating who takes them.
+ -You may accept donations, but they may not be tied to the delivery of a specific product or service.
+
+This is not a complete description of the license. By writing this partial license agreement here, Ludeon Studios does not give up any other rights, express or implied. These notes are simply for clarification.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f20d0dd54a4a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,69 @@
+# Maintainer: Sebastien Duthil <duthils@free.fr>
+
+pkgname=rimworld
+pkgver=0.12.914
+pkgrel=1
+pkgdesc="A sci-fi colony simulation game driven by an intelligent AI storyteller."
+arch=('i686' 'x86_64')
+url="http://rimworldgame.com/"
+license=('custom: commercial')
+depends=('glu' 'lib32-gtk2' 'gcc-libs-multilib')
+makedepends=('unzip')
+source=(rimworld.desktop
+ rimworld.sh
+ LICENSE)
+sha256sums=('e83c514731904722d96218e82e257467d7af32d938493bb5908cf96c7699cae6'
+ '2cf317e27b0d0414cc0a9dbde784edd5e8f06ab1c71715a869e4578e7febffd3'
+ 'ef210c499f47f0076204227da65110e0f2fe3316b5ae03478c21941a07e513e0')
+if test "$CARCH" == i686; then
+ _rimworld_arch=x86
+elif test "$CARCH" == x86_64; then
+ _rimworld_arch=x86_64
+fi
+_gamepkg=RimWorldAlpha12dLinux.zip
+_pkgpaths_tries=("$startdir"
+ "$HOME/Downloads")
+
+build() {
+ msg "You need a full copy of this game in order to install it"
+
+ # look for game zipfile
+ for pkgpath_try in "${_pkgpaths_tries[@]}" ; do
+ msg "Searching for ${_gamepkg} in dir: \"${pkgpath_try}\""
+ if [[ -f "${pkgpath_try}/${_gamepkg}" ]]; then
+ pkgpath=${pkgpath_try}
+ break
+ fi
+ done
+
+ # not found: ask for path to game zipfile
+ if [[ ! -f "${pkgpath}/${_gamepkg}" ]]; then
+ error "Game package not found, please type absolute path to ${_gamepkg} (/home/joe):"
+ read pkgpath
+ if [[ ! -f "${pkgpath}/${_gamepkg}" ]]; then
+ error "Unable to find game package."
+ return 1
+ fi
+ fi
+
+ # unpack game zipfile
+ msg "Found game package, unpacking..."
+ unzip "${pkgpath}/${_gamepkg}" -d "${srcdir}"
+}
+
+package() {
+ cd "$srcdir"/RimWorld*Linux
+
+ install -d "${pkgdir}/usr/bin"
+ install -d "${pkgdir}/usr/share/applications"
+ install -d "${pkgdir}/usr/share/rimworld"
+ install -d "${pkgdir}/usr/share/licenses/rimworld"
+
+ install -m755 "$srcdir/rimworld.sh" "$pkgdir/usr/bin/rimworld"
+ install -m755 RimWorld*Linux.${_rimworld_arch} "$pkgdir/usr/share/rimworld/rimworld"
+ cp -r RimWorld*Linux_Data "$pkgdir/usr/share/rimworld/Data"
+ cp -r Mods Source "$pkgdir/usr/share/rimworld"
+ install -m644 Readme.txt Version.txt "$pkgdir/usr/share/rimworld"
+ install -m644 "${srcdir}/rimworld.desktop" "${pkgdir}/usr/share/applications/rimworld.desktop"
+ install -m644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/rimworld/LICENSE"
+}
diff --git a/rimworld.desktop b/rimworld.desktop
new file mode 100644
index 000000000000..fb803fe112a4
--- /dev/null
+++ b/rimworld.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Rimworld
+GenericName=Rimworld
+Comment=A sci-fi colony simulation game driven by an intelligent AI storyteller.
+Exec=rimworld
+Icon=/usr/share/rimworld/Data/Resources/UnityPlayer.png
+Terminal=false
+Type=Application
+Categories=Game;
diff --git a/rimworld.sh b/rimworld.sh
new file mode 100644
index 000000000000..846d900073e8
--- /dev/null
+++ b/rimworld.sh
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+# LC_ALL: Apparently Unity has problems with non-english locales
+# Also, the game binary needs to be in the same directory as the game data
+LC_ALL=C /usr/share/rimworld/rimworld