summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastien Duthil2016-08-28 18:26:56 -0400
committerSebastien Duthil2016-08-28 18:26:56 -0400
commitc9a89aa4344b3b90f65516bd6d2bf5c2a75877ab (patch)
treef2c99e1b5287c6e3d2f28b66f58a17336b845c05
parent56dc554c399aed01e740f0c45264c0da35a90384 (diff)
downloadaur-c9a89aa4344b3b90f65516bd6d2bf5c2a75877ab.tar.gz
update to alpha 15
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
-rw-r--r--rimworld.sh15
3 files changed, 19 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9d86fa0dd54c..5acfb51de5df 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = rimworld
pkgdesc = A sci-fi colony simulation game driven by an intelligent AI storyteller.
- pkgver = 0.14.1249
+ pkgver = 0.15.1279
pkgrel = 1
url = http://rimworldgame.com/
arch = i686
@@ -12,7 +12,7 @@ pkgbase = rimworld
source = rimworld.desktop
source = rimworld.sh
sha256sums = e83c514731904722d96218e82e257467d7af32d938493bb5908cf96c7699cae6
- sha256sums = 37be72d82b2cb853b435598ff1fabda03de3a660b9e69b95a03af6548f6dc4c4
+ sha256sums = b43669fb221beda0927781b2572861ba50af08d0dcd8abf6011d27dd894f564e
pkgname = rimworld
diff --git a/PKGBUILD b/PKGBUILD
index c621e9a98dad..43d6653e1c13 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Sebastien Duthil <duthils@free.fr>
pkgname=rimworld
-pkgver=0.14.1249 # see ${srcdir}/Version.txt
+pkgver=0.15.1279 # see ${srcdir}/Version.txt
pkgrel=1
pkgdesc="A sci-fi colony simulation game driven by an intelligent AI storyteller."
arch=('i686' 'x86_64')
@@ -12,13 +12,13 @@ makedepends=('unzip')
source=(rimworld.desktop
rimworld.sh)
sha256sums=('e83c514731904722d96218e82e257467d7af32d938493bb5908cf96c7699cae6'
- '37be72d82b2cb853b435598ff1fabda03de3a660b9e69b95a03af6548f6dc4c4')
+ 'b43669fb221beda0927781b2572861ba50af08d0dcd8abf6011d27dd894f564e')
if test "$CARCH" == i686; then
_rimworld_arch=x86
elif test "$CARCH" == x86_64; then
_rimworld_arch=x86_64
fi
-_gamepkg=RimWorldAlpha14eLinux.zip
+_gamepkg=RimWorldAlpha15Linux.zip
_pkgpaths_tries=("$startdir"
"$HOME/Downloads")
@@ -46,7 +46,7 @@ build() {
# unpack game zipfile
msg "Found game package, unpacking..."
- unzip -u "${pkgpath}/${_gamepkg}" -d "${srcdir}" -x 'RimWorld*Linux/Mods/Core/Languages/Russian/*RimWorld/*'
+ unzip -u "${pkgpath}/${_gamepkg}" -d "${srcdir}" -x 'RimWorld*Linux/Mods/Core/Languages/Russian/*RimWorld/*' 'RimWorld*Linux/Mods/Core/Languages/Russian/*.txt'
}
package() {
diff --git a/rimworld.sh b/rimworld.sh
index ad9857475543..efd2cbe96e5a 100644
--- a/rimworld.sh
+++ b/rimworld.sh
@@ -1,5 +1,16 @@
-#!/bin/sh
+#!/bin/bash
+
+# Code for forcing OpenGL backend taken from upstream start_RimWorld_openglfix.sh
+FORCEGL=""
+
+if which glxinfo | grep -q glxinfo ; then
+ OPENGL_VERSION=`glxinfo | grep "OpenGL version string:" | cut -d' ' -f 4`
+ if [[ (( $OPENGL_VERSION < 3.2 )) ]]; then
+ echo "Detected OpenGL version < 3.2, launching game with a fix"
+ FORCEGL=" -force-opengl"
+ fi
+fi
# LC_ALL: Apparently Unity has problems with non-english locales
# Also, the game binary needs to be in the same directory as the game data
-LC_ALL=C /opt/rimworld/rimworld
+LC_ALL=C /opt/rimworld/rimworld $FORCEGL