summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBaptiste Jonglez2015-06-25 09:49:45 +0200
committerBaptiste Jonglez2015-06-25 09:49:45 +0200
commiteacd1704d0fa56454f098d250ab37a8c30d1dccb (patch)
treeae7b611f7da5a7dc261d691c5467b77b27bf62c9
downloadaur-eacd1704d0fa56454f098d250ab37a8c30d1dccb.tar.gz
Initial upload: libringclient-git 20150623-1
Initial upload: ring-daemon-git 20150623-1 Initial upload: ring-gnome-client-git 20150526-1
-rw-r--r--.SRCINFO35
-rw-r--r--PKGBUILD58
2 files changed, 93 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..219173a59c62
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,35 @@
+pkgbase = ring-daemon-git
+ pkgdesc = SIP/IAX2 compatible softphone for Linux, based on a DHT (formerly known as SFLphone)
+ pkgver = 20150623
+ pkgrel = 1
+ url = http://ring.cx
+ arch = i686
+ arch = x86_64
+ groups = ring
+ license = GPL3
+ makedepends = git
+ makedepends = boost
+ depends = opendht-git
+ depends = yaml-cpp
+ depends = alsa-lib
+ depends = libpulse
+ depends = jack
+ depends = libsamplerate
+ depends = libsndfile
+ depends = dbus-c++
+ depends = ffmpeg
+ depends = udev
+ depends = gnutls
+ depends = expat
+ depends = gsm
+ depends = speex
+ depends = speexdsp
+ depends = opus
+ depends = libupnp
+ provides = ring-daemon
+ conflicts = ring-daemon
+ source = git+https://gerrit-ring.savoirfairelinux.com/ring-daemon
+ md5sums = SKIP
+
+pkgname = ring-daemon-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bb138e079613
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: Baptiste Jonglez <baptiste--aur at jonglez dot org>
+pkgname=ring-daemon-git
+pkgver=20150623
+pkgrel=1
+pkgdesc="SIP/IAX2 compatible softphone for Linux, based on a DHT (formerly known as SFLphone)"
+arch=("i686" "x86_64")
+url="http://ring.cx"
+license=('GPL3')
+groups=("ring")
+depends=('opendht-git' 'yaml-cpp' 'alsa-lib' 'libpulse' 'jack'
+ 'libsamplerate' 'libsndfile' 'dbus-c++' 'ffmpeg' 'udev' 'gnutls'
+ 'expat' 'gsm' 'speex' 'speexdsp' 'opus' 'libupnp')
+makedepends=('git' 'boost')
+provides=('ring-daemon')
+conflicts=('ring-daemon')
+source=("git+https://gerrit-ring.savoirfairelinux.com/ring-daemon")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-git}"
+ git log -1 --format="%cd" --date=short | sed "s|-||g"
+}
+
+build() {
+ cd "${pkgname%-git}"
+
+ msg2 'Building pjproject...'
+ # Build the customised version of pjproject (heavily patched...)
+ mkdir -p contrib/native
+ cd contrib/native
+ ../bootstrap
+ make .pjproject
+
+ cd ../..
+ msg2 'Building...'
+ # Build dring
+ ./autogen.sh
+ ./configure \
+ --prefix=/usr \
+ --sbindir=/usr/bin \
+ --libexecdir=/usr/bin \
+ --sysconfdir=/etc \
+ --enable-ipv6
+ make
+}
+
+package() {
+ cd "${pkgname%-git}"
+
+ msg2 'Installing...'
+ make DESTDIR="$pkgdir" install
+
+ msg2 'Cleaning up pkgdir...'
+ find "$pkgdir" -type d -name .git -exec rm -r '{}' +
+ find "$pkgdir" -type f -name .gitignore -exec rm -r '{}' +
+}
+
+# vim:set ts=2 sw=2 et: