summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKenwoodFox2022-01-03 17:20:53 -0500
committerKenwoodFox2022-01-03 17:20:53 -0500
commit00e5f288ca03eeb3f2b4bb851160a944d29265cc (patch)
treeef7944b2dfbdcce03f713299acbd797166b28113
downloadaur-00e5f288ca03eeb3f2b4bb851160a944d29265cc.tar.gz
init, to comit it
-rw-r--r--.SRCINFO68
-rw-r--r--PKGBUILD23
-rw-r--r--ringcentral-bin.install65
3 files changed, 156 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c396743c6d88
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,68 @@
+pkgbase = ringcentral-bin
+ pkgdesc = "Video Conferencing and Web Conferencing Service."
+ pkgver = 21.4.53809.1206
+ pkgrel = 1
+ url = https://www.ringcentral.com
+ install = ringcentral-bin.install
+ arch = x86_64
+ groups =
+ license = MIT
+ depends = alsa-lib
+ depends = atk
+ depends = cairo
+ depends = cuda-tools
+ depends = dbus
+ depends = expat
+ depends = fontconfig
+ depends = freetype2>=2.6
+ depends = gdk-pixbuf2
+ depends = glib2
+ depends = gtk3
+ depends = ibus
+ depends = libdrm
+ depends = libegl
+ depends = libgl
+ depends = libglvnd
+ depends = libpulse
+ depends = libsm
+ depends = libx11
+ depends = libxcb
+ depends = libxcomposite
+ depends = libxcursor
+ depends = libxdamage
+ depends = libxext
+ depends = libxfixes
+ depends = libxi
+ depends = libxkbcommon
+ depends = libxkbcommon-x11
+ depends = libxrender
+ depends = libxslt
+ depends = libxtst
+ depends = nspr
+ depends = nss
+ depends = pango
+ depends = qt5-3d
+ depends = qt5-base
+ depends = qt5-declarative
+ depends = qt5-gamepad
+ depends = qt5-location
+ depends = qt5-multimedia
+ depends = qt5-quickcontrols2
+ depends = qt5-remoteobjects
+ depends = qt5-script
+ depends = qt5-svg
+ depends = qt5-wayland
+ depends = qt5-webchannel
+ depends = qt5-webengine
+ depends = qt5-xmlpatterns
+ depends = sqlite
+ depends = wayland
+ depends = xcb-util-image
+ depends = xcb-util-keysyms
+ depends = zlib
+ options = !strip
+ options = !emptydirs
+ source_x86_64 = https://rcm.ringcentral.com/client/latest/ringcentral_amd64.deb
+ sha512sums_x86_64 = dc97a72252cf1f9a082c2aa21132ba58e0237fec42731413397e8dda1ac30cb3b195604d3c3c3b5bea60344e1131ce05c87931d489c0b483be48d58e572ae56f
+
+pkgname = ringcentral-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..df20bb6f67e4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Generated by debtap
+# Maintainer: Joe
+# Contributor: Joe
+pkgname=ringcentral-bin
+pkgver=21.4.53809.1206
+pkgrel=1
+pkgdesc="Video Conferencing and Web Conferencing Service."
+arch=('x86_64')
+url="https://www.ringcentral.com"
+license=('MIT')
+groups=('')
+depends=('alsa-lib' 'atk' 'cairo' 'cuda-tools' 'dbus' 'expat' 'fontconfig' 'freetype2>=2.6' 'gdk-pixbuf2' 'glib2' 'gtk3' 'ibus' 'libdrm' 'libegl' 'libgl' 'libglvnd' 'libpulse' 'libsm' 'libx11' 'libxcb' 'libxcomposite' 'libxcursor' 'libxdamage' 'libxext' 'libxfixes' 'libxi' 'libxkbcommon' 'libxkbcommon-x11' 'libxrender' 'libxslt' 'libxtst' 'nspr' 'nss' 'pango' 'qt5-3d' 'qt5-base' 'qt5-declarative' 'qt5-gamepad' 'qt5-location' 'qt5-multimedia' 'qt5-quickcontrols2' 'qt5-remoteobjects' 'qt5-script' 'qt5-svg' 'qt5-wayland' 'qt5-webchannel' 'qt5-webengine' 'qt5-xmlpatterns' 'sqlite' 'wayland' 'xcb-util-image' 'xcb-util-keysyms' 'zlib')
+options=('!strip' '!emptydirs')
+install=${pkgname}.install
+source_x86_64=("https://rcm.ringcentral.com/client/latest/ringcentral_amd64.deb")
+sha512sums_x86_64=('dc97a72252cf1f9a082c2aa21132ba58e0237fec42731413397e8dda1ac30cb3b195604d3c3c3b5bea60344e1131ce05c87931d489c0b483be48d58e572ae56f')
+
+package(){
+
+ # Extract package data
+ tar xf data.tar.xz -C "${pkgdir}"
+
+}
diff --git a/ringcentral-bin.install b/ringcentral-bin.install
new file mode 100644
index 000000000000..f6928e6b4b4f
--- /dev/null
+++ b/ringcentral-bin.install
@@ -0,0 +1,65 @@
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+ # Program:
+ # script to be run after package installation
+
+ echo "run post install script, action is $1..."
+
+ update-mime-database /usr/share/mime || true
+ #update-desktop-database || true
+ if [ -x "/usr/bin/update-desktop-database" ]; then
+ update-desktop-database || true
+ fi
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+ # Program:
+ # script to be run after package removal
+
+ echo "run post uninstall script, action is $1 ..."
+
+ [ "$1" = "remove" ] || [ "$1" = "purge" ] ||
+
+ echo current home is $HOME
+
+ if [ -L "/usr/bin/ringcentral" ]; then
+ rm /usr/bin/ringcentral
+ fi
+
+ #$1 folder path
+ function remove_folder
+ {
+ if [ -d $1 ]; then
+ rm -rf $1
+ fi
+ }
+
+ #$1 file path
+ function remove_file
+ {
+ if [ -f $1 ]; then
+ rm -f $1
+ fi
+ }
+
+ remove_folder "/opt/ringcentral"
+ remove_folder "$HOME/.RingCentralMeetings/logs"
+ remove_folder "$HOME/.cache/ringcentral"
+ #remove_file "$HOME/.config/zoomus.conf"
+
+ #logged_in_users=$(who -q | head -n 1)
+ #sorted_users=$(echo "$logged_in_users"|tr " " "\n"|sort|uniq|tr "\n" " ")
+ #for user in $sorted_users;do
+ # echo "removing $(grep -w ^$user /etc/passwd | cut -d ":" -f6)""/.zoom..."
+ ""/.zoom"
+ # echo "removing $(grep -w ^$user /etc/passwd | cut -d ":" -f6)""/.config/zoomus.conf..."
+ ""/.config/zoomus.conf"
+ #done
+ update-desktop-database -q
+}