summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKenwoodFox2022-10-19 10:57:41 -0400
committerKenwoodFox2022-10-19 10:57:41 -0400
commit89eef12ec1452524ea96f4c3af253f552e07a6bb (patch)
tree591c2a5d4f3d10fdb28f61ff9fd7c0c21fcf2cdc
parent994f609a021b3cf73390d4e7246160f885ad2629 (diff)
downloadaur-89eef12ec1452524ea96f4c3af253f552e07a6bb.tar.gz
Move cuda tools (and big deps) to optdepends)
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD8
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a9e5c5037571..e3c36ca70d51 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,23 @@
pkgbase = ringcentral-bin
- pkgdesc = "Video Conferencing and Web Conferencing Service."
+ pkgdesc = Video Conferencing and Web Conferencing Service.
pkgver = 21.4.53809.1206
- pkgrel = 1
+ pkgrel = 2
url = https://www.ringcentral.com
install = ringcentral-bin.install
arch = x86_64
license = MIT
depends = alsa-lib
- depends = atk
+ depends = anaconda
+ depends = at-spi2-core
depends = cairo
- depends = cuda-tools
depends = dbus
depends = expat
depends = fontconfig
depends = freetype2>=2.6
+ depends = gcc-libs
depends = gdk-pixbuf2
depends = glib2
+ depends = glibc
depends = gtk3
depends = ibus
depends = libdrm
@@ -59,6 +61,7 @@ pkgbase = ringcentral-bin
depends = xcb-util-image
depends = xcb-util-keysyms
depends = zlib
+ optdepends = cuda-tools
options = !strip
options = !emptydirs
source_x86_64 = https://rcm.ringcentral.com/client/latest/ringcentral_amd64.deb
diff --git a/PKGBUILD b/PKGBUILD
index df20bb6f67e4..26e02a58d3b9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,21 +3,19 @@
# Contributor: Joe
pkgname=ringcentral-bin
pkgver=21.4.53809.1206
-pkgrel=1
+pkgrel=2
pkgdesc="Video Conferencing and Web Conferencing Service."
arch=('x86_64')
url="https://www.ringcentral.com"
license=('MIT')
-groups=('')
-depends=('alsa-lib' 'atk' 'cairo' 'cuda-tools' 'dbus' 'expat' 'fontconfig' 'freetype2>=2.6' 'gdk-pixbuf2' 'glib2' 'gtk3' 'ibus' 'libdrm' 'libegl' 'libgl' 'libglvnd' 'libpulse' 'libsm' 'libx11' 'libxcb' 'libxcomposite' 'libxcursor' 'libxdamage' 'libxext' 'libxfixes' 'libxi' 'libxkbcommon' 'libxkbcommon-x11' 'libxrender' 'libxslt' 'libxtst' 'nspr' 'nss' 'pango' 'qt5-3d' 'qt5-base' 'qt5-declarative' 'qt5-gamepad' 'qt5-location' 'qt5-multimedia' 'qt5-quickcontrols2' 'qt5-remoteobjects' 'qt5-script' 'qt5-svg' 'qt5-wayland' 'qt5-webchannel' 'qt5-webengine' 'qt5-xmlpatterns' 'sqlite' 'wayland' 'xcb-util-image' 'xcb-util-keysyms' 'zlib')
+depends=('alsa-lib' 'anaconda' 'at-spi2-core' 'cairo' 'dbus' 'expat' 'fontconfig' 'freetype2>=2.6' 'gcc-libs' 'gdk-pixbuf2' 'glib2' 'glibc' 'gtk3' 'ibus' 'libdrm' 'libegl' 'libgl' 'libglvnd' 'libpulse' 'libsm' 'libx11' 'libxcb' 'libxcomposite' 'libxcursor' 'libxdamage' 'libxext' 'libxfixes' 'libxi' 'libxkbcommon' 'libxkbcommon-x11' 'libxrender' 'libxslt' 'libxtst' 'nspr' 'nss' 'pango' 'qt5-3d' 'qt5-base' 'qt5-declarative' 'qt5-gamepad' 'qt5-location' 'qt5-multimedia' 'qt5-quickcontrols2' 'qt5-remoteobjects' 'qt5-script' 'qt5-svg' 'qt5-wayland' 'qt5-webchannel' 'qt5-webengine' 'qt5-xmlpatterns' 'sqlite' 'wayland' 'xcb-util-image' 'xcb-util-keysyms' 'zlib')
+optdepends=('cuda-tools')
options=('!strip' '!emptydirs')
install=${pkgname}.install
source_x86_64=("https://rcm.ringcentral.com/client/latest/ringcentral_amd64.deb")
sha512sums_x86_64=('dc97a72252cf1f9a082c2aa21132ba58e0237fec42731413397e8dda1ac30cb3b195604d3c3c3b5bea60344e1131ce05c87931d489c0b483be48d58e572ae56f')
package(){
-
# Extract package data
tar xf data.tar.xz -C "${pkgdir}"
-
}