summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJianfeng Zhang2017-03-21 17:26:44 +0800
committerJianfeng Zhang2017-03-21 17:26:44 +0800
commitc1971f5138fcb226abb8101c5d2941760bb5f1a4 (patch)
tree66a818fd7b14903b6ee86532874015c769113246
downloadaur-c1971f5138fcb226abb8101c5d2941760bb5f1a4.tar.gz
initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD38
-rw-r--r--patch.diff22
3 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fd2410393287
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# 二 3月 21 09:26:40 UTC 2017
+pkgbase = ringo
+ pkgdesc = Multi-threaded JavaScript on the JVM
+ pkgver = 1.1.1
+ pkgrel = 1
+ url = https://ringojs.org/
+ arch = any
+ license = Apache
+ makedepends = apache-ant
+ makedepends = apache-ivy
+ makedepends = patch
+ depends = java-runtime-headless
+ depends = bash
+ source = git+https://github.com/ringo/ringojs.git#tag=v1.1.1
+ source = patch.diff
+ sha256sums = SKIP
+ sha256sums = 924efdfe4c4f71c36578759edc31bf26c52fcaed3917b813fe34b91f4137a308
+
+pkgname = ringo
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8525185b10b1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Jianfeng Zhang <swordfeng123@gmail.com>
+
+pkgname=ringo
+pkgver=1.1.1
+pkgrel=1
+pkgdesc="Multi-threaded JavaScript on the JVM"
+arch=('any')
+url="https://ringojs.org/"
+license=('Apache')
+depends=('java-runtime-headless' 'bash')
+makedepends=('apache-ant' 'apache-ivy' 'patch')
+source=("git+https://github.com/ringo/ringojs.git#tag=v${pkgver}"
+ 'patch.diff')
+sha256sums=('SKIP'
+ '924efdfe4c4f71c36578759edc31bf26c52fcaed3917b813fe34b91f4137a308')
+
+prepare() {
+ cd "${srcdir}/ringojs"
+ patch -i "${srcdir}/patch.diff" -p0 -s
+}
+
+build() {
+ cd "${srcdir}/ringojs"
+ ant update
+ ant jar
+}
+
+package() {
+ mkdir -p "${pkgdir}/usr/lib/${pkgname}"
+ for name in bin lib modules run.jar; do
+ cp -r "${srcdir}/ringojs/${name}" "${pkgdir}/usr/lib/${pkgname}/${name}"
+ done
+
+ mkdir -p "${pkgdir}/usr/bin"
+ for name in ringo ringo-admin ringo-web; do
+ ln -s "../lib/ringo/bin/${name}" "${pkgdir}/usr/bin/${name}"
+ done
+}
diff --git a/patch.diff b/patch.diff
new file mode 100644
index 000000000000..ff11e9fb4685
--- /dev/null
+++ b/patch.diff
@@ -0,0 +1,22 @@
+diff --git a/test/file/test-fs-ownergroup.js b/test/file/test-fs-ownergroup.js
+index 113ea74c..d23915cf 100644
+--- test/file/test-fs-ownergroup.js
++++ test/file/test-fs-ownergroup.js
+@@ -38,7 +38,7 @@ exports.testChangeOwner = function() {
+ assert.equal(fs.owner(testFile), java.lang.System.getProperty("user.name"));
+
+ assert.throws(function() {
+- fs.changeOwner(testFile, "thisuserdoesnotexistforsureonthissystem" + Date.now());
++ fs.changeOwner(testFile, "doesnotexist" + Date.now());
+ }, java.nio.file.attribute.UserPrincipalNotFoundException);
+ assert.equal(fs.owner(testFile), java.lang.System.getProperty("user.name"));
+ };
+@@ -52,7 +52,7 @@ exports.testChangeGroup = function() {
+ var oldGroup = fs.group(testFile);
+
+ assert.throws(function() {
+- fs.changeGroup(testFile, "thisgroupdoesnotexistforsureonthissystem" + Date.now());
++ fs.changeGroup(testFile, "doesnotexist" + Date.now());
+ }, java.nio.file.attribute.UserPrincipalNotFoundException);
+
+ assert.isTrue(fs.changeGroup(testFile, oldGroup));