summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDidier BONNEFOI2021-03-09 18:02:24 +0100
committerDidier BONNEFOI2021-03-09 18:02:24 +0100
commitb44af2adb20454d8176b4844f2703d889430b178 (patch)
tree6b5e64031c3433f8665ff6c33a2e7f5940a1ab4c
downloadaur-b44af2adb20454d8176b4844f2703d889430b178.tar.gz
initial commit - RingOver 1.3.1
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD20
-rw-r--r--ringover.install16
4 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..defc6ccaefe0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = ringover-bin
+ pkgdesc = Ringover desktop application
+ pkgver = 1.3.1
+ pkgrel = 1
+ url = https://github.com/ringover/ringover-desktop
+ install = ringover.install
+ arch = x86_64
+ license = custom
+ source = https://github.com/ringover/ringover-desktop/releases/download/v1.3.1/Ringover.deb
+ sha512sums = 3cc752b2d06c8ccb593f2a137c58e3f5739c29efae5615ca746b0e1854982e0942496dfed607a80fd0029591e7a6632e91f0cf21db1112292164e3a62e370964
+
+pkgname = ringover-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..479b03739ddf
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg/
+/src/
+*.deb
+*.pkg.tar.zst
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cf6ad3c0146e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Didier BONNEFOI <aur at prestaconcept dot net>
+pkgname=ringover-bin
+pkgver=1.3.1
+pkgrel=1
+pkgdesc="Ringover desktop application"
+arch=('x86_64')
+url="https://github.com/ringover/ringover-desktop"
+license=("custom")
+install=ringover.install
+
+source=("https://github.com/ringover/ringover-desktop/releases/download/v${pkgver}/Ringover.deb")
+sha512sums=("3cc752b2d06c8ccb593f2a137c58e3f5739c29efae5615ca746b0e1854982e0942496dfed607a80fd0029591e7a6632e91f0cf21db1112292164e3a62e370964")
+
+package() {
+ echo "Extracting the data.tar.xz..."
+ bsdtar -xf data.tar.xz -C "${pkgdir}"
+ install -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ mv "${pkgdir}/opt/Ringover/LICENSE.electron.txt" "${pkgdir}/usr/share/licenses/${pkgname}"
+ mv "${pkgdir}/opt/Ringover/LICENSES.chromium.html" "${pkgdir}/usr/share/licenses/${pkgname}"
+}
diff --git a/ringover.install b/ringover.install
new file mode 100644
index 000000000000..11232e64dc9c
--- /dev/null
+++ b/ringover.install
@@ -0,0 +1,16 @@
+post_install()
+{
+ echo "Link to the binary"
+ ln -sfv /opt/Ringover/ringover /usr/bin/ringover
+}
+
+post_upgrade()
+{
+ post_install
+}
+
+post_remove()
+{
+ echo "Delete the link to the binary"
+ rm -fv /usr/bin/ringover
+}