summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2015-08-08 01:00:29 -0400
committerChris Severance2015-08-08 01:00:29 -0400
commitc8123703bf27f21517db9542a0dd3b45eec512c4 (patch)
treebb719ffa3e8575f2e36c20d55f80f3c9e8bd68e0
downloadaur-c8123703bf27f21517db9542a0dd3b45eec512c4.tar.gz
Initial Import
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD62
2 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bfe7896586a6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = riofs-git
+ pkgdesc = FUSE userspace filesystem for Amazon AWS S3 buckets
+ pkgver = v0.5.r60.gc6d8e8e
+ pkgrel = 1
+ url = https://github.com/skoobe/riofs
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = pkg-config
+ makedepends = git
+ depends = fuse
+ depends = glib2
+ depends = libevent
+ depends = libxml2
+ depends = openssl
+ provides = riofs
+ conflicts = riofs
+ source = riofs-git::git+https://github.com/skoobe/riofs.git
+ sha256sums = SKIP
+
+pkgname = riofs-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..39d2943a7b25
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# Maintainer: Chris Severance aur.severach aATt spamgourmet dott com
+# Contributor: Gustavo Lopes <mail@geleia.net>
+
+set -u
+_pkgname=riofs
+pkgname="${_pkgname}-git"
+_srcdir="${pkgname}"
+pkgver=v0.5.r60.gc6d8e8e
+pkgrel=1
+pkgdesc='FUSE userspace filesystem for Amazon AWS S3 buckets'
+arch=('i686' 'x86_64')
+url='https://github.com/skoobe/riofs'
+license=('GPL3')
+depends=('fuse' 'glib2' 'libevent' 'libxml2' 'openssl')
+makedepends=('pkg-config' 'git')
+source=("${_srcdir}::git+https://github.com/skoobe/riofs.git") # #commit=${pkgver##*.g}
+sha256sums=('SKIP')
+conflicts="${_pkgname}"
+provides="${_pkgname}"
+
+pkgver() {
+ set -u
+ cd "${_srcdir}"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ set +u
+}
+
+prepare() {
+ set -u
+ cd "${_srcdir}"
+ ./autogen.sh
+ ./configure --prefix='/usr' --includedir='/usr/include/riofs'
+ set +u
+}
+
+build() {
+ set -u
+ cd "${_srcdir}"
+ make -s -j $(nproc)
+ set +u
+}
+
+package() {
+ set -u
+ cd "${_srcdir}"
+ make -s DESTDIR="${pkgdir}" install
+ set +u
+ # Ensure there are no forbidden paths. Place at the end of package() and comment out as you find or need exceptions. (git-aurcheck)
+ ! test -d "${pkgdir}/bin" || { echo "Line ${LINENO} Forbidden: /bin"; false; }
+ ! test -d "${pkgdir}/sbin" || { echo "Line ${LINENO} Forbidden: /sbin"; false; }
+ ! test -d "${pkgdir}/lib" || { echo "Line ${LINENO} Forbidden: /lib"; false; }
+ ! test -d "${pkgdir}/share" || { echo "Line ${LINENO} Forbidden: /share"; false; }
+ ! test -d "${pkgdir}/usr/sbin" || { echo "Line ${LINENO} Forbidden: /usr/sbin"; false; }
+ ! test -d "${pkgdir}/usr/local" || { echo "Line ${LINENO} Forbidden: /usr/local"; false; }
+ ! grep -lr "/sbin" "${pkgdir}" || { echo "Line ${LINENO} Forbidden: /sbin"; false; }
+ ! grep -lr "/usr/tmp" "${pkgdir}" || { echo "Line ${LINENO} Forbidden: /usr/tmp"; false; }
+ ! grep -lr "/usr/local" "${pkgdir}" || { echo "Line ${LINENO} Forbidden: /usr/local"; false; }
+ ! pcre2grep -Ilr "(?<!/usr)/bin" "${pkgdir}" || { echo "Line ${LINENO} Forbidden: /bin"; false; }
+}
+set +u
+
+# vim:set ts=2 sw=2 et: