summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuca Weiss2017-01-20 21:11:40 +0100
committerLuca Weiss2017-01-20 21:11:40 +0100
commit42eef69eba5d62b5fb14b1f3b868e89557ed0bdd (patch)
treeba43b29e94951b01dbcdac7760946098e4212ef0
parente54a99706c7b02f5c0fb71e1244011d69881e446 (diff)
downloadaur-42eef69eba5d62b5fb14b1f3b868e89557ed0bdd.tar.gz
Remove comments from original PKGBUILD and add new experimental PKGBUILD.new for building from the gpg signed release
-rw-r--r--PKGBUILD5
-rw-r--r--PKGBUILD.new52
2 files changed, 52 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4e1a4aebedd8..0be90f55064e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,12 +7,10 @@ pkgdesc="A glossy Matrix collaboration client for the desktop."
arch=("any")
license=("Apache")
source=("git+https://github.com/vector-im/riot-web.git#tag=v$pkgver"
-#source=("https://github.com/vector-im/riot-web/releases/download/v0.9.5/vector-v0.9.5.tar.gz"{,.asc}
"Riot.desktop"
"riot-web.sh"
"riot.svg"
"riot.png")
-#validpgpkeys=('6FEB6F83D48B93547E7DFEDEE019645248E8F4A1')
url="https://riot.im/"
makedepends=("git" "npm")
depends=("electron")
@@ -29,18 +27,15 @@ prepare() {
}
build() {
-# cd $srcdir/vector-v$pkgver
cd $srcdir/riot-web
npm install
npm run build
}
package() {
-# cd $srcdir/vector-v$pkgver
cd $srcdir/riot-web
mkdir -p $pkgdir/usr/lib/$pkgname/{webapp,electron}
- #cp -r $srcdir/riot-web/* $pkgdir/usr/lib/$pkgname/
cp $srcdir/riot-web/package.json $pkgdir/usr/lib/$pkgname/
cp -r $srcdir/riot-web/webapp/* $pkgdir/usr/lib/$pkgname/webapp/
cp -r $srcdir/riot-web/electron/* $pkgdir/usr/lib/$pkgname/electron/
diff --git a/PKGBUILD.new b/PKGBUILD.new
new file mode 100644
index 000000000000..46d9615917bd
--- /dev/null
+++ b/PKGBUILD.new
@@ -0,0 +1,52 @@
+# Maintainer: Luca Weiss <luca (at) z3ntu (dot) xyz>
+
+pkgname=riot-web
+pkgver=0.9.6
+pkgrel=1
+pkgdesc="A glossy Matrix collaboration client for the desktop."
+arch=("any")
+license=("Apache")
+#options=(!strip)
+source=("https://github.com/vector-im/riot-web/releases/download/v$pkgver/vector-v$pkgver.tar.gz"{,.asc}
+ "https://raw.githubusercontent.com/vector-im/riot-web/v$pkgver/package.json"
+ "https://raw.githubusercontent.com/vector-im/riot-web/v$pkgver/electron/src/"{electron-main.js,squirrelhooks.js,vectormenu.js}
+ "https://raw.githubusercontent.com/vector-im/riot-web/v$pkgver/electron/riot.im/config.json"
+ "Riot.desktop"
+ "riot-web.sh"
+ "riot.svg"
+ "riot.png")
+validpgpkeys=('6FEB6F83D48B93547E7DFEDEE019645248E8F4A1')
+url="https://riot.im/"
+makedepends=("git" "npm")
+depends=("electron")
+sha512sums=('06d81b37ca79db59913c4b66c619363626425b4808387aa9c7c881ba9fcd90c8e23a2a327c29d7db0c94f47f731fd9ace4718c2613a8eb8ca14f07d49cb8e2c5'
+ 'SKIP'
+ 'd1cdcd088b62fe1b94637c5fd750c13715d9eeae6189f2020392c706f140ff77c31daa98eea5df7ecdc40a910061299f58154a8de1efd628e084567fc9cb1644'
+ '928c6c413ef2c0447e42b1f856f52efce106ee91cd71bcfaa123d602f6f837c952a5fff87d270697c5ac75ad7bb922be33c2c40aad60f14b5032c943b6823e3c'
+ '8f0abe4deccd303a689aa593bfdc827db401acc09e966fd3e5a91fe374bcf60514ca85912679af67e721f3cde99c6f18e13414b330900357f63210932554f2f5'
+ 'd94f38491899e128a1450dbe84e5cde95ceee944ef56bbaccc1a6ee20a92105a9e05b2b5aa624a1279db775129c04a22b410c4a3727a73c8a7ba6a989b171215'
+ '0db82b18d49535cbaa504efb590e280a78038aa71365a8be2c708fd14e8b664b51e47a0b3c65300ceb17aeb701091b918ca0118e807dc4fce7d9dd15f9d26026'
+ '103e08dd228967f75bf7f7a84d8764afdc7e88b3eb8d833e909ee8ca56bed3c451b7297c733de1459f37f1d9f50a3f9859879298ebfe92befe44c0785be7903c'
+ '48ec620b07fc57de790abdb1f01048825fa7864d22d3f3494055b3919538868ac9c48048d94ad1655f93da595cc1a06a625170aa070979f98a9d39b5ded34cae'
+ 'bf88f617f7327b73e10d452c4f316f39e999874c25c6eac124036a28508c9ecadcc15e9540c4297903f1bac88cc580c48f69220c455369a8a21eef688071966b'
+ '9bc5c155384bb6d17c9007e9fb17c644db0b86e7c4ca03396d845bdc2916ddf906570bdeca9133d6f09e6920531e742aed31738b4ad77196fdd48e54784d50cf')
+
+package() {
+ cd "$srcdir/vector-v$pkgver"
+
+ mkdir -p "$pkgdir/usr/lib/$pkgname/"{webapp,electron}
+ mkdir -p "$pkgdir/usr/lib/$pkgname/electron/src"
+
+ cp -r "$srcdir/vector-v$pkgver/"* "$pkgdir/usr/lib/$pkgname/webapp/"
+ cp "$srcdir/config.json" "$pkgdir/usr/lib/$pkgname/webapp/"
+ cp "$srcdir/package.json" "$pkgdir/usr/lib/$pkgname/"
+ cp "$srcdir/"*.js "$pkgdir/usr/lib/$pkgname/electron/src/"
+
+ install -Dm644 "$srcdir/Riot.desktop" "$pkgdir/usr/share/applications/Riot.desktop"
+ install -Dm755 "$srcdir/riot-web.sh" "$pkgdir/usr/bin/riot-web"
+
+ install -Dm644 "$srcdir/riot.svg" "$pkgdir/usr/share/icons/hicolor/scalable/apps/riot.svg"
+ install -Dm644 "$srcdir/riot.png" "$pkgdir/usr/share/pixmaps/riot.png"
+}
+
+# vim:set ts=2 sw=2 et: