summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAanok2018-11-27 18:47:49 +0100
committerAanok2018-11-27 18:47:49 +0100
commit7542922692c01b9af1df42cb79a023317273523e (patch)
tree449f911a5322f36cf1fef0015905b7c86cdc030c
parent7833f71315915a56fa65803d54eeddc442b38243 (diff)
downloadaur-7542922692c01b9af1df42cb79a023317273523e.tar.gz
now extracting contents to avoid appimage desktop integration
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD23
2 files changed, 16 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6a560b5f72e1..6ce6f55cd465 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ripcord
pkgdesc = Qt-based Discord and Slack client
pkgver = 0.3.6
- pkgrel = 1
+ pkgrel = 2
url = https://cancel.fm/ripcord/
arch = x86_64
license = custom
diff --git a/PKGBUILD b/PKGBUILD
index 74c179b7478f..adfa03a1fc3b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: therealfarfetchd
pkgname='ripcord'
pkgver=0.3.6
-pkgrel=1
+pkgrel=2
pkgdesc='Qt-based Discord and Slack client'
arch=('x86_64')
depends=('fuse2')
@@ -12,23 +12,28 @@ license=('custom')
validpgpkeys=('ABBAD1CB484F53024CF5868B69332F9203F21F5C')
_file="Ripcord-0.3.6-x86_64.AppImage"
-source=('https://cancel.fm/dl/Ripcord-0.3.6-x86_64.AppImage' 'https://cancel.fm/dl/Ripcord-0.3.6-x86_64.AppImage.asc')
+source=('https://cancel.fm/dl/Ripcord-0.3.6-x86_64.AppImage'
+'https://cancel.fm/dl/Ripcord-0.3.6-x86_64.AppImage.asc')
sha256sums=('1a510ffcf075b8d181415bf160035aa97e0e41cac20bb3e3eb0ebf4dbaed191c' 'SKIP')
# !! AppImage is emptied if symbols are stripped away !!
+# But beyond that, the program is deployed with symbols on purpose
options=('!strip')
-PKGEXT='.pkg.tar'
+# AppImage is already compressed, no reason to compress it again
+# Kept as reminder
+#PKGEXT='.pkg.tar'
prepare() {
- # we extract so we can install the icon and .desktop files
+ # Extract AppImage contents so we install bypassing every and all AppImage
+ # desktop integration/deployment mechanisms
chmod +x "$_file"
"./$_file" --appimage-extract &>/dev/null
}
package() {
install -d "$pkgdir"/usr/bin/
- install -d "$pkgdir"/opt/ripcord/
+ install -d "$pkgdir"/usr/lib/ripcord/
install -d "$pkgdir"/usr/share/applications/
install -d "$pkgdir"/usr/share/icons/
@@ -37,7 +42,9 @@ package() {
sed -i 's/Exec=Ripcord/Exec=\/usr\/bin\/ripcord/' squashfs-root/Ripcord.desktop
install -m644 squashfs-root/Ripcord.desktop "$pkgdir"/usr/share/applications
- install "$_file" "$pkgdir"/opt/ripcord
- ln -s /opt/ripcord/"$_file" "$pkgdir"/usr/bin/ripcord
-}
+ chmod 755 -R squashfs-root/lib squashfs-root/plugins squashfs-root/plugins/*
+ mv squashfs-root/* "$pkgdir"/usr/lib/ripcord/
+ ln -s /usr/lib/ripcord/Ripcord "$pkgdir"/usr/bin/ripcord
+ rm {'..','.'}/"$_file"{'','.asc'}
+}