summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLars Toenning2020-02-22 14:10:02 +0100
committerLars Toenning2020-02-22 14:10:02 +0100
commit3aa6e831355b5789aeb6dc67a160740633b7eb83 (patch)
tree0a7589ee300aa254212029ba452990c4e538455f
downloadaur-3aa6e831355b5789aeb6dc67a160740633b7eb83.tar.gz
Initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD46
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..061201264dd6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = ripes-git
+ pkgdesc = A graphical processor simulator and assembly editor for the RISC-V ISA
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = https://github.com/mortbopet/Ripes
+ arch = x86_64
+ license = MIT
+ makedepends = cmake
+ depends = qt5-base
+ source = ripes-git-2.0.0::git+https://github.com/mortbopet/Ripes.git
+ source = git+https://github.com/mortbopet/VSRTL.git
+ source = ELFIO::git+https://github.com/serge1/ELFIO.git
+ source = git+https://github.com/pbhogan/Signals.git
+ source = better-enums::git+https://github.com/mortbopet/better-enums.git
+ source = cereal::git+https://github.com/USCiLab/cereal.git
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = ripes-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..08761724d073
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: ltoenning <dev@ltoenning.de>
+pkgname=ripes-git
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="A graphical processor simulator and assembly editor for the RISC-V ISA"
+arch=('x86_64')
+url="https://github.com/mortbopet/Ripes"
+license=('MIT')
+depends=('qt5-base')
+makedepends=('cmake')
+
+
+source=("${pkgname}-${pkgver}::git+https://github.com/mortbopet/Ripes.git"
+'git+https://github.com/mortbopet/VSRTL.git'
+'ELFIO::git+https://github.com/serge1/ELFIO.git'
+'git+https://github.com/pbhogan/Signals.git'
+'better-enums::git+https://github.com/mortbopet/better-enums.git'
+'cereal::git+https://github.com/USCiLab/cereal.git'
+)
+sha256sums=('SKIP'
+'SKIP'
+'SKIP'
+'SKIP'
+'SKIP'
+'SKIP')
+
+prepare(){
+ cp -r $srcdir/VSRTL/* $srcdir/${pkgname}-${pkgver}/external/VSRTL
+ cp -r $srcdir/ELFIO/* $srcdir/${pkgname}-${pkgver}/external/ELFIO
+
+ cp -r $srcdir/better-enums/* $srcdir/${pkgname}-${pkgver}/external/VSRTL/external/better-enums
+ cp -r $srcdir/cereal/* $srcdir/${pkgname}-${pkgver}/external/VSRTL/external/cereal
+ cp -r $srcdir/Signals/* $srcdir/${pkgname}-${pkgver}/external/VSRTL/external/Signals
+}
+
+build(){
+ cd $srcdir/${pkgname}-${pkgver}
+ cmake -DCMAKE_BUILD_TYPE=Release
+ make -j $(nproc)
+}
+
+package(){
+ sed -i 's/Exec=Ripes/Exec=ripes/g' "$srcdir/${pkgname}-${pkgver}/appdir/usr/share/applications/Ripes.desktop"
+ install -Dm 755 "$srcdir/${pkgname}-${pkgver}/Ripes" "$pkgdir/usr/bin/ripes"
+ install -Dm 644 "$srcdir/${pkgname}-${pkgver}/appdir/usr/share/applications/Ripes.desktop" "${pkgdir}/usr/share/applications/Ripes.desktop"
+}