summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLars Toenning2021-11-18 21:52:01 +0100
committerLars Toenning2021-11-18 21:52:01 +0100
commit7e63053864302b4c196e5e18913763fc6931bacb (patch)
tree55dd7d9c07f0da9eaaa498c04a3d0887186c5234
parentc9c4976528abbfd2b6b07e9bac40cd5409c79d07 (diff)
downloadaur-7e63053864302b4c196e5e18913763fc6931bacb.tar.gz
Fix compilation and update version to 2.2.3
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD32
2 files changed, 25 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c68a837b91be..c8232b2df076 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ripes-git
pkgdesc = A graphical processor simulator and assembly editor for the RISC-V ISA
- pkgver = 2.1.0
+ pkgver = 2.2.3
pkgrel = 1
url = https://github.com/mortbopet/Ripes
arch = x86_64
@@ -9,10 +9,10 @@ pkgbase = ripes-git
makedepends = git
depends = qt5-base
depends = qt5-charts
- source = ripes-git-2.1.0::git+https://github.com/mortbopet/Ripes.git
- source = git+https://github.com/mortbopet/VSRTL.git
+ source = ripes-git-2.2.3::git+https://github.com/mortbopet/Ripes.git
+ source = VSRTL::git+https://github.com/mortbopet/VSRTL.git
source = ELFIO::git+https://github.com/serge1/ELFIO.git
- source = git+https://github.com/pbhogan/Signals.git
+ source = Signals::git+https://github.com/pbhogan/Signals.git
source = better-enums::git+https://github.com/mortbopet/better-enums.git
source = cereal::git+https://github.com/USCiLab/cereal.git
sha256sums = SKIP
@@ -23,4 +23,3 @@ pkgbase = ripes-git
sha256sums = SKIP
pkgname = ripes-git
-
diff --git a/PKGBUILD b/PKGBUILD
index d198388e7d50..294c8bb65f72 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: ltoenning <dev@ltoenning.de>
pkgname=ripes-git
-pkgver=2.1.0
+pkgver=2.2.3
pkgrel=1
pkgdesc="A graphical processor simulator and assembly editor for the RISC-V ISA"
arch=('x86_64')
@@ -11,9 +11,9 @@ makedepends=('cmake' 'git')
source=("${pkgname}-${pkgver}::git+https://github.com/mortbopet/Ripes.git"
-'git+https://github.com/mortbopet/VSRTL.git'
+'VSRTL::git+https://github.com/mortbopet/VSRTL.git'
'ELFIO::git+https://github.com/serge1/ELFIO.git'
-'git+https://github.com/pbhogan/Signals.git'
+'Signals::git+https://github.com/pbhogan/Signals.git'
'better-enums::git+https://github.com/mortbopet/better-enums.git'
'cereal::git+https://github.com/USCiLab/cereal.git'
)
@@ -25,22 +25,32 @@ sha256sums=('SKIP'
'SKIP')
prepare(){
- cp -r $srcdir/VSRTL/* $srcdir/${pkgname}-${pkgver}/external/VSRTL
- cp -r $srcdir/ELFIO/* $srcdir/${pkgname}-${pkgver}/external/ELFIO
+ mkdir -p $srcdir/${pkgname}-${pkgver}/build
+ cd $srcdir/${pkgname}-${pkgver}
+
+ # Configure git submodules
+ git submodule init
+ git config submodule.external/ELFIO.url "$srcdir/ELFIO"
+ git config submodule.external/VSRTL.url "$srcdir/VSRTL"
+ git submodule update
- cp -r $srcdir/better-enums/* $srcdir/${pkgname}-${pkgver}/external/VSRTL/external/better-enums
- cp -r $srcdir/cereal/* $srcdir/${pkgname}-${pkgver}/external/VSRTL/external/cereal
- cp -r $srcdir/Signals/* $srcdir/${pkgname}-${pkgver}/external/VSRTL/external/Signals
+ # Configure git submodules of submodules
+ cd $srcdir/${pkgname}-${pkgver}/external/VSRTL
+ git submodule init
+ git config submodule.external/better-enums.url "$srcdir/better-enums"
+ git config submodule.external/cereal.url "$srcdir/cereal"
+ git config submodule.external/Signals.url "$srcdir/Signals"
+ git submodule update
}
build(){
- cd $srcdir/${pkgname}-${pkgver}
- cmake -DCMAKE_BUILD_TYPE=Release
+ cd $srcdir/${pkgname}-${pkgver}/build
+ cmake -DCMAKE_BUILD_TYPE=Release ..
make -j $(nproc)
}
package(){
sed -i 's/Exec=Ripes/Exec=ripes/g' "$srcdir/${pkgname}-${pkgver}/appdir/usr/share/applications/Ripes.desktop"
- install -Dm 755 "$srcdir/${pkgname}-${pkgver}/Ripes" "$pkgdir/usr/bin/ripes"
+ install -Dm 755 "$srcdir/${pkgname}-${pkgver}/build/Ripes" "$pkgdir/usr/bin/ripes"
install -Dm 644 "$srcdir/${pkgname}-${pkgver}/appdir/usr/share/applications/Ripes.desktop" "${pkgdir}/usr/share/applications/Ripes.desktop"
}