summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLars Toenning2022-01-04 23:12:16 +0100
committerLars Toenning2022-01-04 23:12:16 +0100
commit8d15079b335ea1066ebd56b0606986ca771474c9 (patch)
tree131ec9f0c9d04b9c334aa314d20071088c0f4792
parent7e63053864302b4c196e5e18913763fc6931bacb (diff)
downloadaur-8d15079b335ea1066ebd56b0606986ca771474c9.tar.gz
Fix compilation with upstream
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD24
2 files changed, 23 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c8232b2df076..54c23f760fab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ripes-git
pkgdesc = A graphical processor simulator and assembly editor for the RISC-V ISA
pkgver = 2.2.3
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/mortbopet/Ripes
arch = x86_64
license = MIT
@@ -12,6 +12,8 @@ pkgbase = ripes-git
source = ripes-git-2.2.3::git+https://github.com/mortbopet/Ripes.git
source = VSRTL::git+https://github.com/mortbopet/VSRTL.git
source = ELFIO::git+https://github.com/serge1/ELFIO.git
+ source = libelfin::git+https://github.com/mortbopet/libelfin.git
+ source = cpp-mmaplib::git+https://github.com/yhirose/cpp-mmaplib.git
source = Signals::git+https://github.com/pbhogan/Signals.git
source = better-enums::git+https://github.com/mortbopet/better-enums.git
source = cereal::git+https://github.com/USCiLab/cereal.git
@@ -21,5 +23,7 @@ pkgbase = ripes-git
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
pkgname = ripes-git
diff --git a/PKGBUILD b/PKGBUILD
index 294c8bb65f72..ffd8af63efad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: ltoenning <dev@ltoenning.de>
pkgname=ripes-git
pkgver=2.2.3
-pkgrel=1
+pkgrel=2
pkgdesc="A graphical processor simulator and assembly editor for the RISC-V ISA"
arch=('x86_64')
url="https://github.com/mortbopet/Ripes"
@@ -13,14 +13,18 @@ makedepends=('cmake' 'git')
source=("${pkgname}-${pkgver}::git+https://github.com/mortbopet/Ripes.git"
'VSRTL::git+https://github.com/mortbopet/VSRTL.git'
'ELFIO::git+https://github.com/serge1/ELFIO.git'
+'libelfin::git+https://github.com/mortbopet/libelfin.git'
+'cpp-mmaplib::git+https://github.com/yhirose/cpp-mmaplib.git'
'Signals::git+https://github.com/pbhogan/Signals.git'
'better-enums::git+https://github.com/mortbopet/better-enums.git'
'cereal::git+https://github.com/USCiLab/cereal.git'
)
-sha256sums=('SKIP'
-'SKIP'
-'SKIP'
-'SKIP'
+sha256sums=('SKIP'
+'SKIP'
+'SKIP'
+'SKIP'
+'SKIP'
+'SKIP'
'SKIP'
'SKIP')
@@ -32,15 +36,23 @@ prepare(){
git submodule init
git config submodule.external/ELFIO.url "$srcdir/ELFIO"
git config submodule.external/VSRTL.url "$srcdir/VSRTL"
+ git config submodule.external/libelfin.url "$srcdir/libelfin"
git submodule update
- # Configure git submodules of submodules
+ # Configure git submodules of VSRTL
cd $srcdir/${pkgname}-${pkgver}/external/VSRTL
git submodule init
git config submodule.external/better-enums.url "$srcdir/better-enums"
git config submodule.external/cereal.url "$srcdir/cereal"
git config submodule.external/Signals.url "$srcdir/Signals"
git submodule update
+
+ # Configure git submodules of libelfin
+ cd $srcdir/${pkgname}-${pkgver}/external/libelfin
+ git submodule init
+ git config submodule.external/cpp-mmaplib.url "$srcdir/cpp-mmaplib"
+ git submodule update
+
}
build(){