summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorphiresky2020-04-17 10:37:43 +0200
committerphiresky2020-04-17 10:37:43 +0200
commit049d21360d44e48e5825cf3bcf64113509b24eb3 (patch)
tree445e93b29d94e8b3c7aac9a857baa91c6838fd2e
parentaf306fc6b4166a03aa39e2573d7754f63f0b09d2 (diff)
downloadaur-049d21360d44e48e5825cf3bcf64113509b24eb3.tar.gz
update
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 05ec41790854..0d6aaaf348ab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ripgrep-all
pkgdesc = rga: ripgrep, but also search in PDFs, E-Books, Office documents, zip, tar.gz, etc.
- pkgver = 0.9.3
+ pkgver = 0.9.5
pkgrel = 1
url = https://github.com/phiresky/ripgrep-all
arch = i686
@@ -21,8 +21,8 @@ pkgbase = ripgrep-all
conflicts = rga
conflicts = rga-git
conflicts = rga-bin
- source = https://github.com/phiresky/ripgrep-all/archive/0.9.3.tar.gz
- sha512sums = fc898130e9c5c3666e14bb7f7f1cc5c069a614eea2aa58e84e2267ea1cfcbab8a9272b56f997b7418088950fd5f119c9af050677d28c5a2287b7671dee0d629e
+ source = https://github.com/phiresky/ripgrep-all/archive/v0.9.5.tar.gz
+ sha512sums = b881503d412b882f03036e748e50fa80ce463cb2d0f670ee76a21853dc3ccf307d680ab0fb8d0a4302f3b6c40ca64d62b2f6fca84fb6323ee1af50d4f6eeae47
pkgname = ripgrep-all
diff --git a/PKGBUILD b/PKGBUILD
index cf04214eb90c..3a8c253f09ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Julien Nicoulaud <julien DOT nicoulaud AT gmail DOT com>
pkgname=ripgrep-all
-pkgver=0.9.3
+pkgver=0.9.5
pkgrel=1
pkgdesc="rga: ripgrep, but also search in PDFs, E-Books, Office documents, zip, tar.gz, etc."
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
@@ -11,17 +11,17 @@ license=('AGPL3')
depends=(ripgrep ffmpeg pandoc poppler tesseract imagemagick)
makedepends=('rust' 'cargo')
conflicts=("${pkgname}-git" "${pkgname}-bin" "rga" "rga-git" "rga-bin")
-source=("https://github.com/phiresky/ripgrep-all/archive/${pkgver}.tar.gz")
-sha512sums=('fc898130e9c5c3666e14bb7f7f1cc5c069a614eea2aa58e84e2267ea1cfcbab8a9272b56f997b7418088950fd5f119c9af050677d28c5a2287b7671dee0d629e')
+source=("https://github.com/phiresky/ripgrep-all/archive/v${pkgver}.tar.gz")
+sha512sums=('b881503d412b882f03036e748e50fa80ce463cb2d0f670ee76a21853dc3ccf307d680ab0fb8d0a4302f3b6c40ca64d62b2f6fca84fb6323ee1af50d4f6eeae47')
build() {
cd "${srcdir}/ripgrep-all-${pkgver}"
- cargo build --release --locked
+ cargo build --release --locked --target-dir=$PWD/target
}
check() {
cd "${srcdir}/ripgrep-all-${pkgver}"
- cargo test --release --locked
+ cargo test --release --locked --target-dir=$PWD/target
}
package() {